[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [SOLVED] silent5.test failure (was: Re: Automake 1.11.1 glitch?)

From: Bob Friesenhahn
Subject: Re: [SOLVED] silent5.test failure (was: Re: Automake 1.11.1 glitch?)
Date: Tue, 7 Sep 2010 12:01:16 -0500 (CDT)
User-agent: Alpine 2.01 (GSO 1266 2009-07-14)

On Tue, 7 Sep 2010, Stefano Lattarini wrote:

You've got it Toyota!

Here in the USA, we were inundated for many years by adds from Toyota with the above message. :-)

And by looking at the files `tests/silent5.dir/Makefile' and
`tests/silent5.dir/config.log', it's easy to detect the problem.

It seems that you have somehow defined in your environment `F77'
to `no' (probably through your config.site), and the current tests'
setup code in `tests/defs.in'  fails to force the redefintion of
that environment variable to `gfortran' when running a test that
requires a Fortran compiler.  So yes, this is a testsuite weakness.

Yes. For many years, I did not install the Fortran components of GCC. I set these variables to 'no' in config.site because the Sun Fortran components were otherwise used by mistake in the libtool test suite. More recently, I have started to install the Fortran components so I should be able to remove the overrides. Since I try to enforce using a particular GCC version in config.site, I will probably set this definition to use gfortran.

Bob Friesenhahn
address@hidden, http://www.simplesystems.org/users/bfriesen/
GraphicsMagick Maintainer,    http://www.GraphicsMagick.org/

reply via email to

[Prev in Thread] Current Thread [Next in Thread]