[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[SOLVED] silent5.test failure (was: Re: Automake 1.11.1 glitch?)

From: Stefano Lattarini
Subject: [SOLVED] silent5.test failure (was: Re: Automake 1.11.1 glitch?)
Date: Tue, 7 Sep 2010 18:51:56 +0200
User-agent: KMail/1.13.3 (Linux/2.6.30-2-686; KDE/4.4.4; i686; ; )

Hello Bob, thanks for helping me through this.

On Tuesday 07 September 2010, Bob Friesenhahn wrote:
> On Tue, 7 Sep 2010, Stefano Lattarini wrote:
> >> tests/silent5.log and config.log are attached.  From
> >> tests/silent5.log I see that 'no' is being passed as a command
> >> to bash, so it is likely that there is a test suite weakness.
> > 
> > Darn, I've been sloppy: I should have also asked you to provide
> > us with the (tarred) content of the temporary test directory
> > `tests/silent5.dir'.  Could you kindly send this over to the list
> > too?
> You've got it Toyota!

> I see that it is 235KB so hopefully it will make it through to
> the list.
It did :-)

And by looking at the files `tests/silent5.dir/Makefile' and 
`tests/silent5.dir/config.log', it's easy to detect the problem.

It seems that you have somehow defined in your environment `F77'
to `no' (probably through your config.site), and the current tests'
setup code in `tests/defs.in'  fails to force the redefintion of
that environment variable to `gfortran' when running a test that
requires a Fortran compiler.  So yes, this is a testsuite weakness.

JFTR, there is a pending patch series of mine that should take care of 
such problems:
Reveiews by anyone interested are welcome ;-)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]