[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#55511: 13.1.3; TeX-auto-store issues with complex paths

From: Arash Esbati
Subject: bug#55511: 13.1.3; TeX-auto-store issues with complex paths
Date: Sun, 22 May 2022 20:16:43 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/29.0.50

Cyril Arnould <cyril.arnould@outlook.com> writes:

> I didn't really manage to install AUCTeX from the git repo though. My
> emacs installation comes from MSYS2
> (https://packages.msys2.org/package/mingw-w64-x86_64-emacs) and when I
> tried to run the ./configure script in the MINGW64 environment, it
> failed because of some sed error.

Did you run ./autogen.sh before ./configure?

We have instructions for using AUCTeX from a local Git repo described
here[1].  Maybe that is easier for testing purposes.

> Running it from the MSYS environment instead seemed to have worked, it
> installed the package to C:\msys64\mingw64\share\emacs\site-lisp. So I
> removed my old AUCTeX
> package from the .emacs.d folder, but for some reason my .emacs file
> kept reinstalling it from ELPA even though the site-lisp folder is part
> of the load-path... I load it via use-package:

> ;; AUCTeX
> (use-package latex
>   :ensure auctex)

I'd say this is the expected behavior[2]:

  The :ensure keyword causes the package(s) to be installed automatically
  if not already present on your system:

  (use-package magit
    :ensure t)

  If you need to install a different package from the one named by
  use-package, you can specify it like this:

  (use-package tex
    :ensure auctex)

I don't use use-package, but I think you need to use-package tex and not latex.

Best, Arash


[2]  https://github.com/jwiegley/use-package#package-installation

reply via email to

[Prev in Thread] Current Thread [Next in Thread]