[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Axiom-developer] wh-sandbox and aldor

From: Franz Lehner
Subject: [Axiom-developer] wh-sandbox and aldor
Date: Thu, 31 May 2007 19:26:03 +0200 (CEST)


since apparently there is no amd64 binary package I tried to
compile one myself and started with wh-sandbox.
It finished after 12 hours (with --enable-checking).

Then I tried to follow the instructions on

fetched and installed


$ make --version
GNU Make 3.80

$ javac -version
javac 1.5.0_10

unpacked src_aldor2.tgz into

document Makefile.pamphlet
apparently is not enough, as the other pamphlets are not unpacked.

what does
"set AXIOM environment variables"
Should it point to the source or to the target?

So far I tried
export AXIOM=/usr/local/src/axiom/wh-sandbox/build/x86_64-unknown-linux
because it makes most sense with the other variables in the Makefile.

Make.rules:365, 399, 412:
No file found for "include"

Make.rules:204: wh-sandbox/int/aldor/sax0/ File not found

indeed the only file there is
and then it complains about plenty of missing *.dep files:
wh-sandbox/int/aldor/gendeps/AF.dep: File not found

should I try another branch? If yes, which one?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]