[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Axiom-developer] wh-sandbox and aldor

From: Martin Rubey
Subject: Re: [Axiom-developer] wh-sandbox and aldor
Date: 31 May 2007 19:32:53 +0200
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.4

Dear Franz,

Franz Lehner <address@hidden> writes:

> since apparently there is no amd64 binary package I tried to compile one
> myself and started with wh-sandbox.  It finished after 12 hours (with
> --enable-checking).


> Then I tried to follow the instructions on
> fetched and installed

> fetched
> $ make --version
> GNU Make 3.80
> $ javac -version
> javac 1.5.0_10
> unpacked src_aldor2.tgz into
> wh-sandbox/src/aldor

I believe it's better to do an out of source build of wh-sandbox.  Below are
some notes I took for myself.

> document Makefile.pamphlet
> apparently is not enough, as the other pamphlets are not unpacked.

> what does
> "set AXIOM environment variables"
> mean?
> Should it point to the source or to the target?

I believe it should be "target", see below.

> should I try another branch? If yes, which one?

no, wh-sandbox should be fine.

Please let me know if this worked, in which case I'll update AldorForAxiom.



out of source build in ax-build:

!!! check version of make (3.81 beta 4 does not work !!!

put or link document into ax-build/target/i686-pc-linux/bin

extract src_aldor2.tar into ax-build/src/aldor

cd ax-build/src/aldor
document Makefile.pamphlet

export AXIOM=~/ax-build/target/i686-pc-linux/
## make stops with
# make[1]: *** No rule to make target
`/home/martin/ax-build/int/aldor/'.  Stop.
# make[1]: Leaving directory `/home/martin/ax-build/src/aldor'
# make: *** [all] Error 2

touch ../../int/aldor/dep_spad.stamp
document Make.functions.pamphlet

# if build stops complaining that "no rule to make target ... axlit ", check
  version of make again

reply via email to

[Prev in Thread] Current Thread [Next in Thread]