[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Axiom-developer] Mac OS X 10.4.8 PowerPC success!

From: Raymond Manzoni
Subject: Re: [Axiom-developer] Mac OS X 10.4.8 PowerPC success!
Date: Sun, 5 Nov 2006 02:01:32 +0100

Le 4 nov. 06 à 18:56, Humberto Ortiz-Zuazaga a écrit :

Raymond Manzoni wrote:
    And thanks for providing this binary!
My machine is a Dual G5 running OS X 10.4.8 (PPC build 8L127, Darwin Kernel Version 8.8.0, PowerMac7,2 Darwin similar to your configuration I
think...)  and your binary worked here too!  Great!!


The gcl generation ends (depending on paths and/or parameter) with
either a gcl readline error :
gcl_readline.d: In function 'rl_completion':
gcl_readline.d:221: warning: implicit declaration of function
gcl_readline.d:221: error: 'rl_compentry_func_t' undeclared (first use
in this function)
gcl_readline.d:221: error: (Each undeclared identifier is reported only
gcl_readline.d:221: error: for each function it appears in.)
gcl_readline.d:221: error: parse error before ')' token

    or the more annoying tk problem :
/usr/bin/ld: warning -L: directory name
(/sw/src/tcltk-8.4.6-2/tk8.4.6/unix) does not exist
/usr/bin/ld: warning multiple definitions of symbol _tclPlatStubsPtr and
/usr/bin/ld: Undefined symbols:

I think these are both symptoms of the gcl configure picking up packages
from fink (/sw/bin, /sw/lib, ...) and having the compile break.

    export CVSROOT=:pserver:address@hidden:/sources/gcl
    cvs -z9 -q co -d gcl-2.6.8pre -r Version_2_6_8pre gcl

    In gcl-2.6.8pre :
    - remove  -lintl  from the LIBS:= line of  h/powerpc-macosx.defs

     export LIBRARY_PATH=`pwd`/binutils/intl

You don't need that anymore if you patch, as we won't use libintl anymore.

I manipulated my PATH to remove /sw/bin and similar, so gcl's configure doesn't see the fink tcl/Tk, I think you can pass some kind of configure
option to gcl to do the same thing, but I kept having wierd problems
until I changed the PATH.

In any case, I used fink's latex and pdflatex for the gcl documentation
build, so you could try something like:

./configure --enable-locbfd --disable-statsysbfd --disable-nls

Thanks for the trick of isolating Fink (/sw/... by default) and DarwinPort (/opt/local/...).
        It worked indeed with exactly these instructions!
I just added two symbolic links in /usr/local/bin : the first since pdflatex was needed for completion of the make and the second (optional) for .dvi generation of the make install :

cd /usr/local/bin               
ln -s /sw/bin/pdflatex pdflatex
ln -s /sw/bin/tex tex

        sudo make install

installed gcl so that I could start the (very long...) axiom compilation (NRLIBS generation)

        I got the SIGCLD errors and applied your corrections :

in sselect.c.pamphlet and viewman.c.pamphlet replace :
#if defined(BSDplatform)
#if defined(BSDplatform) || defined(MACOSXplatform)

        I got stuck with the hyper problem :
13 making /Users/raym/Desktop/dev/axio/axiom/src/hyper
make[2]: *** No rule to make target `addfile.pamphlet', needed by `addfile.h'. Stop.
make[1]: *** [hyper/stamp] Error 2
make: *** [all-recursive] Error 1
I fear there is an order problem here since the hthits.pamphlet doesn't exist in the 'hyper' folder at this point (as opposed to the older axiom projects I have).

        I'll stop here (it's late in France).

Thanks again for the help (I don't forget Tim, Bill, Aurelien and many others!)
        Best regards,

all on one line. Good luck.

Humberto Ortiz-Zuazaga
University of Puerto Rico

reply via email to

[Prev in Thread] Current Thread [Next in Thread]