[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Axiom-developer] Mac OS X 10.4.8 PowerPC success!

From: Raymond Manzoni
Subject: Re: [Axiom-developer] Mac OS X 10.4.8 PowerPC success!
Date: Sat, 4 Nov 2006 15:59:22 +0100

Le 4 nov. 06 à 13:25, Humberto Ortiz-Zuazaga a écrit :

Bill Page wrote:

You only show running the Axiom main console program AXIOMsys.
How about the other parts of Axiom? If you type the command:

  $ axiom

No, sman didn't build. Make stops on viewman:

21 finished making /Users/humberto/src/axiom-darcs/src/Gdraws
1 making /Users/humberto/src/axiom-darcs/src/graph/viewman
gcc -O2 -fno-strength-reduce -Wall -D_GNU_SOURCE -DMACOSXplatform
      -I/usr/include -I/usr/include/sys -I/usr/X11R6/include
-I/Users/humberto/src/axiom-darcs/src/include -I. -c -o sselect.o sselect.c
sselect.c: In function 'superSelect':
sselect.c:94: error: 'SIGCLD' undeclared (first use in this function)
sselect.c:94: error: (Each undeclared identifier is reported only once
sselect.c:94: error: for each function it appears in.)
make[3]: *** [sselect.o] Error 1
make[2]: *** [viewman/stamp] Error 2
make[1]: *** [graph/stamp] Error 2
make: *** [all-recursive] Error 1

I haven't had time to look at the errors yet.

Finally, would you be willing to post a tarball of the Axiom
binaries distribution?

        Hi Humberto,

        And thanks for providing this binary!
My machine is a Dual G5 running OS X 10.4.8 (PPC build 8L127, Darwin Kernel Version 8.8.0, PowerMac7,2 Darwin similar to your configuration I think...) and your binary worked here too! Great!!

In fact I tried earlier to repeat your manipulations to compile from source and could repeat the second part (use adacs to get axiom source and so on) but the first part (install gcl) didn't work here...

The gcl generation ends (depending on paths and/or parameter) with either a gcl readline error :
gcl_readline.d: In function 'rl_completion':
gcl_readline.d:221: warning: implicit declaration of function 'rl_completion_matches' gcl_readline.d:221: error: 'rl_compentry_func_t' undeclared (first use in this function) gcl_readline.d:221: error: (Each undeclared identifier is reported only once
gcl_readline.d:221: error: for each function it appears in.)
gcl_readline.d:221: error: parse error before ')' token

        or the more annoying tk problem :
/usr/bin/ld: warning -L: directory name (/sw/src/tcltk-8.4.6-2/ tk8.4.6/unix) does not exist /usr/bin/ld: warning multiple definitions of symbol _tclPlatStubsPtr and others...
/usr/bin/ld: Undefined symbols:
        (at this point there was a usable saved_gcl but...)

I did this (and some variants without --disable-nls or the export line and so on...) :

        Get a working gcl with CVS :
        export CVS_RSH=ssh
        export CVSROOT=:pserver:address@hidden:/sources/gcl
        cvs -z9 -q co -d gcl-2.6.8pre -r Version_2_6_8pre gcl

        In gcl-2.6.8pre :
        - remove  -lintl  from the LIBS:= line of  h/powerpc-macosx.defs

        export LIBRARY_PATH=`pwd`/binutils/intl
        ./configure --enable-locbfd --disable-statsysbfd --disable-nls

        With the results previously given...

Do you see something inappropriate in the previous lines or could you give me the commands you used to successfully compile gcl on PPC?

        In any case many thanks again for your binary!

Humberto Ortiz-Zuazaga
University of Puerto Rico

Axiom-developer mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]