[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Axiom-developer] build failure on Debian Woody Solved -- Stray symbols

From: Balbir Thomas
Subject: [Axiom-developer] build failure on Debian Woody Solved -- Stray symbols in src/algebra/Makefile ! ??
Date: Wed, 23 Mar 2005 23:34:26 -0500
User-agent: Mutt/1.5.4i

I managed to fix the build failure problem, on Debian/Woody
described in my earlier post. 

The problems seems to have been stray backslashes being placed
before dollar signs. A few sample lines showing this are given below.
This seems to happen only in src/algebra/Makefile . Making the
substitution "s/\\\$/$/g" and restarting the build process fixes
the problem.

\${MID}/ABELGRP.spad: \${IN}/catdef.spad.pamphlet
        \${TANGLE} -R"category ABELGRP 
\${MID}/ABELGRP.lsp: \${IN}/catdef.spad.pamphlet
        \${TANGLE} -R"ABELGRP.lsp 

\${MID}/ABELGRP-.lsp: \${IN}/catdef.spad.pamphlet
        \${TANGLE} -R"ABELGRP-.lsp 

I do not understand why this is happening. Apparently it does not happen on
newer versions of debian as can be seen from the successfull builds on  Please note this is not a problem with the debian
package as it occurs if I try to compile with the upstream source too.

B Thomas

reply via email to

[Prev in Thread] Current Thread [Next in Thread]