[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Axiom-developer] build failure on Debian Woody Solved -- Stray symb

From: Balbir Thomas
Subject: Re: [Axiom-developer] build failure on Debian Woody Solved -- Stray symbols in src/algebra/Makefile ! ??
Date: Thu, 24 Mar 2005 17:25:56 -0500
User-agent: Mutt/1.5.4i


>As Bill Page pointed out the problem is not in noweb
>but in a shell script embedded in the src/algebra/Makefile.pamphlet
>and the semantics of awk.
>Which version of awk are you using? The configure script tries
>to figure out which one you have. It prefers gawk, then nawk, and
>defaults to awk. You can specify a particular awk version on the
>command line thus:
I was using the version 3.1.0 of Gawk . The testing/unstable version
of gawk is 3.1.4. I have compiled this for debian stable and will
install and try to build again. This should tell us if gawk is 
the only problem. 

I was planning on making available the compiled deb packages for
others who use debian stable. So I hope gawk's new version is
not needed beyond compilation.

>make AWK=/usr/local/bin/gawk
>We'll fix the makefile shell script at the next update (expected
>on april 1).

Looks like build failed again with the error :
BOOT>cp: cannot create regular file
`/home/bt/archive/axiom/mnt/linux/algebra/RETRACT-.NRLIB/code.o': No such file
or directory
make[4]: *** [/home/bt/archive/axiom/int/algebra/RETRACT-.NRLIB/code.o] Error 1
make[4]: Leaving directory `/home/bt/archive/axiom/src/algebra'
make[3]: *** [algebradir] Error 2
make[3]: Leaving directory `/home/bt/archive/axiom/src'
make[2]: *** [srcdir] Error 2
make[2]: Leaving directory `/home/bt/archive/axiom'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/bt/archive/axiom'
make: *** [build-stamp] Error 2

This error occurs even though the file
/home/bt/archive/axiom/int/algebra/RETRACT-.NRLIB/code.o exists !

Rather than try to spend another day or two to figure out what is going on
I shall first try to build with the new gawk as it takes many hours to build
on my system. Hopefully this is another manifestation of gawk problems.

b thomas

reply via email to

[Prev in Thread] Current Thread [Next in Thread]