[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Call for help with MACOSX Re: [Axiom-developer] [MACOSX] What is unexec

From: Camm Maguire
Subject: Call for help with MACOSX Re: [Axiom-developer] [MACOSX] What is unexec and why does it fail ?
Date: 21 Mar 2005 08:25:26 -0500
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.2


This is an official call for help from someone familiar with the Mac
and in particular with its mach-o binary file format.  We have an in
general very high quality custom port of the gcl object relocation and
image writing code to this platform graciously contributed by
Aurelien, but it appears that he is no longer reachable, and there are
large image issues with his code in acl2 as well.  I have access to a
Mac account and can ascend the learning curve here if necessary -- it
would simply be much more efficient if someone with the requisite
knowledge already in hand would step forward.

Take care,

Pierre Doucy <address@hidden> writes:

> Hi all,
> Attempting to compile Axiom on my Mac, I get the following error :
> [...]
> 44 invoking make in
> /Users/pdoucy/Documents/Travail/Axiom/axiom--MACOSX--1--patch-1/src/boot
> with parms:
> LSP= /Users/pdoucy/Documents/Travail/Axiom/axiom--MACOSX--1--patch-1/lsp
> PART= cprogs
> SPAD= 
> /Users/pdoucy/Documents/Travail/Axiom/axiom--MACOSX--1--patch-1/mnt/MACOSX
> SRC= /Users/pdoucy/Documents/Travail/Axiom/axiom--MACOSX--1--patch-1/src
> INT= /Users/pdoucy/Documents/Travail/Axiom/axiom--MACOSX--1--patch-1/int
> OBJ= /Users/pdoucy/Documents/Travail/Axiom/axiom--MACOSX--1--patch-1/obj
> MNT= /Users/pdoucy/Documents/Travail/Axiom/axiom--MACOSX--1--patch-1/mnt
> unexec: not enough room for load commands for new __DATA segments
> make[3]: *** 
> [/Users/pdoucy/Documents/Travail/Axiom/axiom--MACOSX--1--patch-1/obj/MACOSX/bin/bootsys]
> Error 1
> make[2]: *** [bootdir] Error 2
> make[1]: *** [srcdir] Error 2
> make: *** [all] Error 2
> As it looked like a memory problem, I changed my gcl configure options to:
> ./configure --enable-vssize=65536*4 --enable-maxpage=256*1024
> --enable-machine=powerpc-macosx --enable-dlopen --disable-locbfd
> but still get the same error.
> After some googling, I haven't been able to find any clear doc about
> what unexec is, and what it does.
> Can anyone explain me what it is supposed to do, and why it might fail
> in such a manner ?
> Thank you in advance.
> Pierre DOUCY
> -- 
> Cats are intended to teach us that not everything in nature has a function.
> _______________________________________________
> Axiom-developer mailing list
> address@hidden

Camm Maguire                                            address@hidden
"The earth is but one country, and mankind its citizens."  --  Baha'u'llah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]