[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Axiom-developer] [MACOSX] What is unexec and why does it fail ?

From: Pierre Doucy
Subject: [Axiom-developer] [MACOSX] What is unexec and why does it fail ?
Date: Thu, 17 Mar 2005 16:17:31 +0100

Hi all,

Attempting to compile Axiom on my Mac, I get the following error :

44 invoking make in
with parms:
LSP= /Users/pdoucy/Documents/Travail/Axiom/axiom--MACOSX--1--patch-1/lsp
PART= cprogs
SPAD= /Users/pdoucy/Documents/Travail/Axiom/axiom--MACOSX--1--patch-1/mnt/MACOSX
SRC= /Users/pdoucy/Documents/Travail/Axiom/axiom--MACOSX--1--patch-1/src
INT= /Users/pdoucy/Documents/Travail/Axiom/axiom--MACOSX--1--patch-1/int
OBJ= /Users/pdoucy/Documents/Travail/Axiom/axiom--MACOSX--1--patch-1/obj
MNT= /Users/pdoucy/Documents/Travail/Axiom/axiom--MACOSX--1--patch-1/mnt
unexec: not enough room for load commands for new __DATA segments
make[3]: *** 
Error 1
make[2]: *** [bootdir] Error 2
make[1]: *** [srcdir] Error 2
make: *** [all] Error 2

As it looked like a memory problem, I changed my gcl configure options to:

./configure --enable-vssize=65536*4 --enable-maxpage=256*1024
--enable-machine=powerpc-macosx --enable-dlopen --disable-locbfd

but still get the same error.
After some googling, I haven't been able to find any clear doc about
what unexec is, and what it does.
Can anyone explain me what it is supposed to do, and why it might fail
in such a manner ?

Thank you in advance.

Pierre DOUCY
Cats are intended to teach us that not everything in nature has a function.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]