[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


From: Greg BOGNAR
Date: Sat, 28 Jan 2006 12:12:19 +0100 (CET)

> * Greg BOGNAR (2006-01-26) writes:

>> I have bibligraphy databases in a dedicated directory.  I set
>> BIBINPUTS for that directory.

> How do you set BIBINPUTS?  In my case I have
> BIBINPUTS = .;$TEXMF/bibtex/bib//
> in /etc/texmf/texmf.cnf.

Same here.  But I want to set it to ~/Documents/bibliographies or
something like that, not ~/texmf/bibtex/bib.  My bibliography
databases should be kept together with the rest of my documents.

>> When I run BibTeX in bash, it sees the databases in that directory.
>> When I use Emacs, it does not find those files.  Running BibTeX
>> from Emacs (+ AUCTeX) gives an error message like "I couldn't open
>> database file bibliography.bib ---line 5 of file mydoc.aux"

> How do you run BibTeX from Emacs?

> As an example I created a file foo.bib in
> /home/angeli/texmf/bibtex/bib and a LaTeX file with the contents


> somewhere else.  After running LaTeX with `C-c C-c RET' and BibTeX
> with `C-c C-c BibTeX RET' I get the following output in the output
> buffer for the document (accessible with `C-c C-l'):


The very same steps here, but with error messages.

Meanwhile, I got a solution from Fernando Tusell, I hope he does not
mind that I copy parts of his message here:

> I had a problem similar to yours: starting a session under bash, I
> could find files pointed to by BIBINPUTS, but not otherwise.

> It turned out that when I started Emacs from a graphical session in
> Gnome, the file .bashrc (where the environment variable BIBINPUTS is
> set) was not read. The simple fix in my case was to set BIBINPUTS in
> file .gnomerc (and later I found that making a link from .gnomerc to
> .bashrc also works, and I only have to change and maintain .bashrc).

I use Fvwm, and the solution was the same: I just set BIBINPUTS again
in my .fvwm/config.  Now it all works.  But I doubt it has to do with
the graphical session; it does not work when I run Emacs without X.  
It seems that Emacs does not read .bashrc at all.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]