[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Swftools-common] Problem executing this Command on Linux Server

From: Ricardo Pedroso
Subject: Re: [Swftools-common] Problem executing this Command on Linux Server
Date: Tue, 8 Dec 2009 00:48:11 +0000

On Mon, Dec 7, 2009 at 6:42 AM, Tariq Zubairy <address@hidden> wrote:
> Hi,
> I have approximately 40 pdf files in a directory... I want to convert all
> these PDFs to SWFs. For this i need pdf information so that i can convert
> all the pages of PDFs to SWF pages.
> Out of these 40 PDF's I get error in almost 20 files...
> To get PDF information i use the following command
> CommandText: pdf2swf '-I' '-Q' '20'
> '/opt/lampp/htdocs/test_files/temp/abc.pdf
> and get the following error...
> Error: Unable to get pdf information

Is this error message from pdf2swf or from you php script?

> NOTE: This command executed successfully when I run this manually with
> different user context (on LINUX Server) for that specific PDFs whereas
> fails to execute when run through the php script under webmaster user. If
> there is some problem with the user rights then all files should give the
> same error through webmaster user but almost in 50% cases, it gives required
> information. I did not get any issue with PHP script with windows server.
> Any body having any idea ????

There isn't a direct  answer to this.

Some tips:
If you have root access you can "su - webmaster" to manually run pdf2swf.

You can use "top" or "htop" to check the amount of memory that each
pdf conversion take,
and see if you have a consistent behavior, like, the ones that are
failing consume more memory.

You can try to increase the php "memory_limit"


reply via email to

[Prev in Thread] Current Thread [Next in Thread]