[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Swftools-common] Installing SWFTools on Linux with yum

From: LivingDocs
Subject: Re: [Swftools-common] Installing SWFTools on Linux with yum
Date: Thu, 13 Aug 2009 17:08:27 +0200

Thank you to all who gave me tips and advices how to compile SWFTools on Linux!

Finally I got it to work.


Am 12.08.2009 um 12:22 schrieb John Francis Lee:

LivingDocs wrote:
Hello again,
nobody there who can give me an advice how to solve my problems compiling SWFTools?

I don't know if this is much help for a MAC user on a linux that uses yum. I use ubuntu, which is a linux that uses apt-get for the same purpose. I was able just to

apt-get install g++

Maybe you can too? Sometimes linux'es have both types of package management. Alternatively there must be some way for yum to tell you what the proper package name is for g++. Finding the correct package name is a pain in the butt no matter which system you use.

But after you do get g++ installed you will discover another problem : the xpdf code is not included with in the git clone. So you will need to go to copy


You can go to


and find click'able links for the above.

Then, assuming those 4 files are in the same directory,

tar xzvf xpdf-3.02.tar.gz
cd xpdf-3.02
patch -p1 < ../xpdf-3.02pl1.patch
patch -p1 < ../xpdf-3.02pl2.patch
patch -p1 < ../xpdf-3.02pl3.patch
cd ..
tar czvf xpdf-3.02p3.tar.gz xpdf-3.02

and then copy the xpdf-3.02p3.tar.gz file to the


directory, wherever that maybe, and run the commands I found here :


specifically :

# I changed this first command from xpdf-3.01.tar.gz
perl inject-xpdf.pl xpdf-3.02.tar.gz
# this second command complained but worked somehow
./switch stable
# I think it should be
./switch latest

but all it does is

ln -s xpdf-3.02p3 xpdf

which you might do by hand. That would make the 2 commands :

perl inject-xpdf.pl xpdf-3.02.tar.gz
ln -s xpdf-3.02p3 xpdf

The last is what I would do if I did it again.




sudo make install

And it "just works" :)

Maybe there's an easier way... but that's what worked for me.

There's another posting

Re: [Swftools-common] lib/art/Makefile.in

in which I tried to explain what I did to Matthias, but I assumed he knew what I was trying to talk about.

I hope you have some idea as well :)

Am 06.08.2009 um 10:52 schrieb LivingDocs:
After installing libtool, gcc and make I could run ./configure.

When running make I get an error:

make[2]: g++: Command not found
make[2]: *** [GFXOutputDev.ol Error 127
make[2]: Leaving directory '/root/swftools-0.9.0/lib/pdf'
make[1]: *** [libpdf.al Error 2
make[1]: Leaving directory '/root/swftools-0.9.0/lib'
make: *** [all] Error 2

I tried yum install g++
But it was not found.

For a long-time Mac user this is really a big adventure!


Am 05.08.2009 um 18:24 schrieb Matthias Kramm:

On Wed, Aug 05, 2009 at 04:44:39PM +0200, LivingDocs <address@hidden > wrote:
there is no dicerctory '/usr/share/libtool/' on my server.

When I run cp /usr/share/libtool/config.guess I get the error:

cp: cannot stat '/usr/share/libtool/config.guess': No such file or

Same with '/usr/share/libtool/config.sub'.

Hm. Try
 yum install libtool


John Francis Lee
1025/37 Thanon Jet Yod
Mueang Chiangrai 57000

reply via email to

[Prev in Thread] Current Thread [Next in Thread]