[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Swftools-common] Re: compiling swftools-0.8.1 on windows

From: Novice Programmer
Subject: Re: [Swftools-common] Re: compiling swftools-0.8.1 on windows
Date: Wed, 26 Mar 2008 04:18:57 +0530

finally i got the pdf2swf compiled on ming. here are problems which i fell into.. may be you can save some time.. i started with the installation from .. http://lists.gnu.org/archive/html/swftools-common/2005-02/msg00023.html

1. the newer setups of the libraries listed on the above page dont have statically linked libraries so if you want to link libraries statically to pdf2swf either build all the above said libraries or you link them dynamically and push them into windows/system32 for pdf2swf to launch.

2. the problem with newer declaration of function unlink in stdio.h differs from what is being externd in xpdf/stream.cc.. change the declartion of the function to match what is being given in stdio...

3. Dont miss to change config.h in pdf directory to say #defined boolean unsigned char. if you dont do this then libjpeg will bounce back to you if pdf contains jpeg when you execute pdf2swf on such a file.

4. its easier to do the process on cygwin's full installation. All the libraries and static versions come along with the cygwin install only.

5. Read the errors carefully.. :).

Hope it helps.


On Wed, Mar 26, 2008 at 2:57 AM, Novice Programmer <address@hidden> wrote:
fixed the issue. the problem is that in xpdf the signature of unlink is given as int unlink(char*) where it is int unlink(const char *), changing tit  in stream.cc in xpdf fixed the problem
but now i am stuck with another issue. launching pdf2swf gives an error on jpeg62.dll not found. Any ideas on what this can be?


On Wed, Mar 26, 2008 at 12:16 AM, Novice Programmer <address@hidden> wrote:
just noted that all other tools compiled but pdf2swf... getting the same error whatever i do.. i tried moving to the xpdf directory to compile it and get the same error.


On Tue, Mar 25, 2008 at 10:44 PM, Novice Programmer <address@hidden> wrote:
Hello Mathias,

but then i get the following error while compiling releases:

no rule to make target ../lib/libpdf

i thought that it might be due to g++ so i installed C++ compiler but then i started getting following error:

xpdf/stream.cc : error: declaration of C function int unlink(char **) conficts with some thing....

Please help.


On Tue, Mar 25, 2008 at 5:08 AM, Matthias Kramm <address@hidden> wrote:
On Tue, Mar 25, 2008 at 04:50:18AM +0530, Novice Programmer <address@hidden> wrote:
> do you mean the linux tarballs kept on swftools.org when you say
> swftools/lib/pdf? I might be looking at some other place but believe me i
> can't find even a single *.pl in swftools-0.8.0 or swftools-0.8.1... :(

If you are compiling the releases, not the CVS version, you don't need
to run inject-xpdf.pl. xpdf is already unpacked and patched in the releases.



Thanks & Regards,
Novice (http://ishuonweb.wordpress.com/).

Thanks & Regards,
Novice (http://ishuonweb.wordpress.com/).

Thanks & Regards,
Novice (http://ishuonweb.wordpress.com/).

Thanks & Regards,
Novice (http://ishuonweb.wordpress.com/).
reply via email to

[Prev in Thread] Current Thread [Next in Thread]