[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[rdiff-backup-users] backups failing

From: Richard Hector
Subject: [rdiff-backup-users] backups failing
Date: Mon, 5 Feb 2018 23:59:23 +1300
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.6.0

Hi all,

I have a problem with an (inherited) rdiff-backup setup - actually used
from backupninja.

When I try to run a backup, I get:

OSError: [Errno 2] No such file or directory:

I get the same thing if I run with --check-destination-dir.

I'm not clear why the file is missing, but probably due to a backup that
stopped part way through for some reason.

I'm also not clear why the file needs to be there in the first place -
should there be one for every directory for every backup (that hasn't
been deleted yet)?

I've tried just copying the previous one to the name that's missing
(they're all size 0), and am re-running --check-destination-dir. I
suspect it won't be the only file affected though.

It's a bit fiddly, because I don't have shell access to the destination
machine - it's rsync.net, and I can only run certain provided commands.
I guess that also means I couldn't patch the remote copy of
rdiff-backup, if I found a way to fix it.

Any tips?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]