[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [rdiff-backup-users] Changing ownership of files in archive

From: Robert Nichols
Subject: Re: [rdiff-backup-users] Changing ownership of files in archive
Date: Mon, 24 Oct 2011 18:33:59 -0500
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20110928 Red Hat/3.1.15-1.el6_1 Thunderbird/3.1.15

On 10/24/2011 02:47 PM, zero wrote:
Robert Nichols wrote:
Can't this be handled with the --user-mapping-file and
--group-mapping-file options described in the "USERS AND GROUPS" section of
the manual? If not, it would help if you would describe what you have tried
and what the result or specific error was. Just saying "cannot get
rdiff-backup to work" isn't terribly useful.

When moving the files to a new computer, the owner changed for some reason to
one that doesn't exist on the new computer. When I try to run rdiff-backup -l
I get this error: Fatal Error: Bad directory stuff.current.bak.admin.num. It
doesn't appear to be an rdiff-backup destination dir

This is easily solved by chowning the files in the backup directory to user
that exist on the new computer. This removes the error message. I realize
that the uid and gid and username recorded in the rdiff-backup-data folder is
now inconsistent with the current data. Despite this everything seems to work
fine. I can restore files. The only thing is that when I restore files and
then compare the restored files with the backup directory I see that the
metadata has changed. So I just backup the newly restored data again to
update the records in rdiff-backup directory. But is there a possibility that
this inconsistency of metadata in archive can make it impossible to get back
old files somewhere down the road?

I can't figure out what could be causing the problem you are seeing.  I
have an external drive containing backup sets from several different
systems, and I have no trouble at all listing and restoring files for
user IDs that don't exist on the current system.  If I try to do that
from a non-root UID that doesn't have permission to access some of those
directories on the backup, I get an explicit "permission denied"
message.  The only way I get the messages you are seeing is when I
deliberately give rdiff-backup the name of a directory that doesn't
exist or indeed is not part of an rdiff-backup set.

Changing the ownership of files in the mirror _should_ be harmless.
Indeed, rdiff-backup can store its backups on file systems that don't
support Unix-like ownership and permissions.  But, that change is
certainly not something I have tried, so I can't be sure that there are
no obscure implications.

Bob Nichols     "NOSPAM" is really part of my email address.
                Do NOT delete it.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]