[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[rdiff-backup-users] Changing ownership of files in archive

From: zero
Subject: [rdiff-backup-users] Changing ownership of files in archive
Date: Mon, 24 Oct 2011 12:47:56 -0700

Robert Nichols wrote:
Can't this be handled with the --user-mapping-file and --group-mapping-file 
options described in the "USERS AND GROUPS" section of the manual? If not, it 
would help if you would describe what you have tried and what the result or 
specific error was. Just saying "cannot get rdiff-backup to work" isn't 
terribly useful.

When moving the files to a new computer, the owner changed for some reason to 
one that doesn't exist on the new computer. When I try to run rdiff-backup -l I 
get this error:
Fatal Error: Bad directory stuff.current.bak.admin.num.
It doesn't appear to be an rdiff-backup destination dir

This is easily solved by chowning the files in the backup directory to user 
that exist on the new computer. This removes the error message. I realize that 
the uid and gid and username recorded in the rdiff-backup-data folder is now 
inconsistent with the current data. Despite this everything seems to work fine. 
I can restore files. The only thing is that when I restore files and then 
compare the restored files with the backup directory I see that the metadata 
has changed. So I just backup the newly restored data again to update the 
records in rdiff-backup directory. But is there a possibility that this 
inconsistency of metadata in archive can make it impossible to get back old 
files somewhere down the road?

|This was sent by address@hidden via Backup Central.
|Forward SPAM to address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]