[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [rdiff-backup-users] Unable to restore interrupted backup

From: Dominic Raferd
Subject: Re: [rdiff-backup-users] Unable to restore interrupted backup
Date: Sun, 10 Jul 2011 14:19:53 +0100
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20110424 Thunderbird/3.1.10

On 10/07/11 09:26, abschiedsstein wrote:
On 08/07/2011 13:30, abschiedsstein wrote:
I used rdiff-backup for a while and everything was fine. Backups were fast and 
restoring was no problem.
Then, after an interrupted backup, the data was broken. Neither restoring nor 
fixing with --check-destination-dir was possible.
I guess there is somekind of a standard routine to fix this, but I was not able 
to figure it out until now.
Before I get into details, here are some information about my machine.

OS: Ubuntu 10.10
rdiff-backup: rdiff-backup 1.2.8
The backup directory is on an external usb drive.(NTFS)

When I tried to restore a file I got the message that the last backup was interrupted and that I 
should run --check-destination-dir (so far, so good). I did this. There were many messeges like 
"... metadata, but could not be constructed from existing increments because last increment 
had type ..." . When I now run --check-destination-dir again, I get : "Fatal Error: 
Destination dir /media/TREKSTOR/Sicherungen/neodata-backup/home does not need checking". BUT 
restoring is still not possible:

rdiff-backup -r now /media/TREKSTOR/backupdir/Desktop/protokoll.pdf 
Warning: Could not restore file .!
A regular file was indicated by the metadata, but could not be
constructed from existing increments because last increment had type
dir. Instead of the actual file's data, an empty length file will be
created. This error is probably caused by data loss in the
rdiff-backup destination directory, or a bug in rdiff-backup
I would like to know a way to fix the backup. It would be completely sufficient 
if everything since the last successful backup would be deleted.
I hope someone can help me. Thanks in advance.

On 08 Jul 2011 17:31 Dominic Raferd wrote :

I attach a bash script which automates the process of forcibly regressing an 
rdiff-backup repository. You can use this to override the 'does not need 
checking' message.

Help is built in, just run the script without parameters to see. It does
a single step regression, it can be run multiple times if you need to
regress the repository back further. All the usual caveats apply.


Thanks for the reply. I am awefully sorry, but i cant find your attachment. Am 
I too stupid to find it, or did you forget it.

It was attached but I guess because somewhere along the line it got removed, probably because it is a shell script. I attach it as a tar file which might help it get through.


Attachment: rdiff-backup-regress.sh.tar
Description: Unix tar archive

reply via email to

[Prev in Thread] Current Thread [Next in Thread]