[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[rdiff-backup-users] Unable to restore interrupted backup

From: abschiedsstein
Subject: [rdiff-backup-users] Unable to restore interrupted backup
Date: Fri, 08 Jul 2011 05:30:18 -0700

I used rdiff-backup for a while and everything was fine. Backups were fast and 
restoring was no problem. 
Then, after an interrupted backup, the data was broken. Neither restoring nor 
fixing with --check-destination-dir was possible.
I guess there is somekind of a standard routine to fix this, but I was not able 
to figure it out until now.
Before I get into details, here are some information about my machine.

OS: Ubuntu 10.10
rdiff-backup: rdiff-backup 1.2.8
The backup directory is on an external usb drive.(NTFS)

When I tried to restore a file I got the message that the last backup was 
interrupted and that I should run --check-destination-dir (so far, so good). I 
did this. There were many messeges like "... metadata, but could not be 
constructed from existing increments because last increment had type ..." . 
When I now run --check-destination-dir again, I get : "Fatal Error: Destination 
dir /media/TREKSTOR/Sicherungen/neodata-backup/home does not need checking". 
BUT restoring is still not possible:

>rdiff-backup -r now /media/TREKSTOR/backupdir/Desktop/protokoll.pdf 
>Warning: Could not restore file .!

>A regular file was indicated by the metadata, but could not be
>constructed from existing increments because last increment had type
>dir.  Instead of the actual file's data, an empty length file will be
>created.  This error is probably caused by data loss in the
>rdiff-backup destination directory, or a bug in rdiff-backup

I would like to know a way to fix the backup. It would be completely sufficient 
if everything since the last successful backup would be deleted.
I hope someone can help me. Thanks in advance.


|This was sent by address@hidden via Backup Central.
|Forward SPAM to address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]