[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Mingw-cross-env-list] Last issues before the release [PATCH]

From: Mark Brand
Subject: Re: [Mingw-cross-env-list] Last issues before the release [PATCH]
Date: Thu, 20 May 2010 20:12:55 +0200
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20100430 SUSE/3.1b2-7.1 Thunderbird/3.1b2

Thanks for the hint I needed to discover the obvious. It worked for me only
because pthreads had not been built yet! After doing so, it the vmime failed
for me just as it did for Volker.

I think the solution is in the attached patch. See embedded commit message.
Could you please try it?
That seems to have fixed it and it builds successfully now. However, I
thought the idea was to disable pthreads for vmime and the fix would
be to patch configure to not detect it. I was trying to wrap an
AC_ARG_ENABLE around the ACX_PTHREAD macro (configure.in:527) but
didn't get very far.

Is there a reason now that we don't want pthreads used in vmime? I might be wrong, but I thought Volker added "--without-pthread" as a workaround before the problems with pthread were sorted out. You guys know more about pthreads than I do.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]