[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: lynx-dev Sources for Latest Lynx

From: Mark Mentovai
Subject: Re: lynx-dev Sources for Latest Lynx
Date: Thu, 17 Feb 2000 17:27:19 -0500 (EST)

Martin McCormick wrote:
>       I got the file openssl-0.9.1c.tar.gz and the only odd thing
>about it was that the Configure script did not work and gave an error
>as if it was not executable, but it was.  I tried make to see what that
>would do and it worked.  Make test also seemed to work as well as make
>       I then used patch and the file lynx-282-ssl.patch on the
>sources for lynx2-8-2rel.1 dated June of 99 and the configure and make
>went like a charm.  Everything works but the finished product and it
>works on non-ssl links in a normal way.
>       Is there any newer ssl patch that goes with the newer versions
>of lynx?  As I said, this isn't hard, but I have this feeling I may
>have the wrong version of lynx with the wrong patch or something like
>Martin McCormick
Martin McCormick wrote:
>       I have just spent most of a day trying to get lynx to work
>with SSL and the process isn't all that difficult, but I have made a
>mistake somewhere because I didn't get a secure link when running the
>suggested test.  I got a message that read:
>   Hello, user from -- (139.78.-.-)
>   You are using Lynx, but no secure connection was made. Please try
>   again.

The test page is on the fritz again.  I will fix it.  Your Lynx probably has
working SSL support if you got that far - to be sure, try some known https
URLs.  It sounds like you've got the correct version of Lynx with the
correct version of the patch.

The official place to get the Lynx 2.8.2 source is, this is mirrored in various places.  The
2.8.3 development source is at

The SSL patch is at  OpenSSL is at, the current version is 0.9.4.  The SSL patch page
refers to an older version of OpenSSL, this will be rectified once Lynx
2.8.3 is released.

If you experience trouble getting the SSL patch to work with the release
version of lynx, try a development version.  There is a known problem
getting Lynx to build with newer versions of OpenSSL that has been fixed in
the patch to the 2.8.3dev.  The current version of the SSL patch for the
2.8.3 development series was prepared against dev17 and is compatible with
dev18 and dev20.


Do not reply directly to this e-mail address
Mark Mentovai
GGN NOC System Administrator

reply via email to

[Prev in Thread] Current Thread [Next in Thread]