[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

lynx-dev Possible Y2K issue with Lynx

From: Jon Anderson
Subject: lynx-dev Possible Y2K issue with Lynx
Date: Wed, 05 Jan 2000 15:26:31 +0000

Part of my operation here involves the use of LYNX to get and print
invoices from a webserver which generates printable pages via PHP and

I used to have a line of code in a shell script which looked like 

lynx -source

This accessed a password protected page embedding the password in the
as you would do with a standard webbrowser.

This worked for months and fed the output to a html-postscript converter
and to our printer. Hundreds of invoices have been printed.

Since Jan 1st 2000 this now exits with the message "cannot access start
file" and displays a message indicating that authorisation is required.

If I change the command line to include a -auth= parameter then
everything works
fine, but the URL syntax no longer seems to work.

The versions of LYNX I've tried are 2.6 and 2.8.1, both show the same
result. I'm running Apache 1.3.9 with PHP 3.0.12.

I searched on the net and couldn't find any reference to this issue,
which makes
me think that this must be some other weird bug present in my system and
not an
issue with Lynx.

Despite this, I decided to post my findings to this list in hope of
finding an
answer. Can anyone confirm this is a Y2K issue?

I've changed my scripts to use the -auth parameter and everything now
works again. This indicates to me that the problem is LYNX as nothing
has been changed on these
servers except that the date is now Y2K.

Please reply via email directly as well to the list as I am not directly

Best Regards,

Jon Anderson

reply via email to

[Prev in Thread] Current Thread [Next in Thread]