[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: lynx-dev lynxcgi problem

From: Klaus Weide
Subject: Re: lynx-dev lynxcgi problem
Date: Tue, 21 Dec 1999 08:58:06 -0600 (CST)

On Tue, 21 Dec 1999, Henry Nelson wrote:

> For the first time, I tried using Lynx itself in a lynxcgi script, but
> it didn't work.  What silly thing am I doing wrong?

It looks right, unless there's something strange with your shell...
or even your lynx (any private patches regarding TERM?)

> If I use csh, I
> get a blank page.  If I use sh, I get a message saying I have to set
> my TERM environment variable; 

(Let's stick with a sh if possible...)
Do you have an alternative sh?  i.e. bash, (pd)ksh, ash?  (not tcsh)

Try to figure out where the message comes from:

- from some init script the shell interprets automatically on startup?
- from "echo"? (Hey, let's cover everything :) )
- from lynx?

> if I export TERM, I get a blank page as
> with csh.  The script is simply:

Did you chmod +x it?  Does it run as ./<name-of-script-here> ?
What happens when you insert a line
   unset TERM
after the first line?

If the child *lynx* wants to see TERM - although it should *not* need
that for running with -source -
Try to set it in the script.  Bourne sh syntax: "export TERM; TERM=whatever".
Or tell the parent lynx in its lynx.cfg to export *it's* value of TERM.
Option LYNXCGI_ENVIRONMENT:TERM should do that.

> #! /bin/sh           # (or csh)

(The comment should not be there in the real file, of course)

> echo "Content-type: text/html"
> echo ""
> /usr/local/bin/lynx -cfg=/dev/null -source 
> file://localhost/home/about_lynx.html
> It works fine if I use "cat /home/about_lynx.html."  Thanks for any help.

It works for me as given, after removing the comment from the first line
and adjusting paths.  (I tried various shells, all ok.)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]