lwip-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[lwip-devel] [patch #8882] Vector improvements


From: Simon Goldschmidt
Subject: [lwip-devel] [patch #8882] Vector improvements
Date: Mon, 27 Feb 2017 16:03:09 -0500 (EST)
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36

Follow-up Comment #41, patch #8882 (project lwip):

Having a quick look, the patch seems good. The only thing I'm not certain of
is if it's OK to cast 'struct iovec' to the new 'struct netvector'. Especially
the "msg.w.vector++" code in lwip_netconn_do_writemore() could go wrong if the
(externally defined) struct iovec contained more fields than struct netvector
(or was differently aligned).
As to the API_EVENT, I'm unsure too what the meaning of the 'len' is. I guess
the original meaning was bytes, but it has shown during development that this
consumes too many cycles (we only call SENDMINUS when we want to mark a socket
as not readable) and we don't always have a 'len' to be consistent (e.g. call
SENDPLUS from tcp_poll() to unlock a write that is blocked due to RAM
shortage). I haven't monitored lwIP from it's birth though (I have missed the
first ~5 years)...
I guess for clarity, we might want to omit the 'len' parameter for the
SENDPLUS/SENDMINUS calls...

    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/patch/?8882>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.nongnu.org/




reply via email to

[Prev in Thread] Current Thread [Next in Thread]