[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [lmi] Re: To configure wx-2.6.2

From: Greg Chicares
Subject: Re: [lmi] Re: To configure wx-2.6.2
Date: Wed, 14 Nov 2007 04:41:03 +0000
User-agent: Thunderbird (Windows/20070728)

As part of this scheduled task:
  "Automate installation for compiling in ms windows"
I'm reworking the procedure we use to build wx. It mostly follows
this old posting, which I'll now bring up to date so that we have
the rationale in one place.

On 2006-03-20 13:57Z, Greg Chicares wrote:
> [...]
> Anyway, the 'configure' options I'm currently using are:
> # Things that don't use the wx license, even though some of the
> # license differences may be benign [but at least 'gif' is evil]:
>  --disable-gif
>  --disable-apple_ieee
>  --without-libjpeg
>  --without-libtiff
>  --without-regex
> # Options required to build lmi:
>  --enable-monolithic
>  --enable-shared
>  --disable-threads

That should be in CPPFLAGS, not CXXFLAGS.

> # Options that we might not require, but want anyway:
>  --enable-stl
>  --enable-std_iostreams
>  --enable-debug

Auditing this today, I find that we've been using
instead of
in production; I believe we should use the latter instead,
after careful testing.

> # Options whose defaults seem other than ideal:
>  --enable-commondlg
>  --disable-compat24

We've also been using
which I find documented only off the list, in a message whose
relevant portion I'll copy here for completeness:

On 2006-12-02 13:54Z, Greg Chicares wrote:
| Using this 2006-12-01 snapshot:
| I find only one 'lmi' issue with MinGW gcc-3.4.4, though it
| repeats for several source files:
| /MinGW-20050827//bin/g++ -MMD -MF main_wx.d0  -c -I C:/lmi/src/lmi -I -I -I 
-I -I -I
| c:/wx20061201/wxWidgets-2006-12-01/include -I -I -I 
c:/wx20061201/wxWidgets-2006-12-01/contrib/include -I 
C:/opt/lmi/third_party/include -I C:/usr/local/include -I
| C:/usr/local/include/libxml2 -DLMI_WX_NEW_USE_SO  -DLIBXML_USE_DLL -DSTRICT   
 -DWXUSINGDLL -D__WXMSW__ -DBOOST_STRICT_CONFIG   -pedantic-errors -Werror 
-Wall -Wcast-align
| -Wconversion -Wdeprecated-declarations -Wdisabled-optimization -Wimport 
-Wmultichar -Wpacked -Wpointer-arith -Wsign-compare -Wwrite-strings  
-Wno-long-long -std=c++98
| -Wctor-dtor-privacy -Wdeprecated -Wnon-template-friend -Woverloaded-virtual 
-Wpmf-conversions -Wsynth   -Wno-uninitialized    -ggdb -O2   
C:/lmi/src/lmi/main_wx.cpp -omain_wx.o
| In file included from C:/lmi/src/lmi/main_wx.cpp:77:
| c:/wx20061201/wxWidgets-2006-12-01/include/wx/log.h:586:33: anonymous 
variadic macros were introduced in C99
| c:/wx20061201/wxWidgets-2006-12-01/include/wx/log.h:587:39: anonymous 
variadic macros were introduced in C99
| make.EXE[1]: *** [main_wx.o] Error 1
| That code in 'wx/log.h' is guarded with
| but that guard macro doesn't seem configurable. Should a
| 'disable-' or 'without-' option be added to the configury?

[Vadim did that with '--disable-vararg_macros', thanks]

| I find no gcc-3.x option to turn off this warning, as
|   -Wno-long-long
| does for type 'long long' (which isn't in C++98). And I
| find no 'std=' option to specify the union of C++98 and C99,
| which might be okay if it were available; I haven't tested
| '-std=gnu++98' because, even if it suppresses this warning,
| I don't want gcc extensions to C++ in general.
| Apparently gcc itself overrides this instead of making it
| configurable:
|   http://gcc.gnu.org/ml/gcc-cvs/2004-03/msg00354.html
| | * engine/compiler.h: Don't ever define HAVE_VARIADIC_MACROS, -pedantic
| | whines about them even when we know we can use them.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]