[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Can't add new modules

From: Martell, Larry
Subject: RE: Can't add new modules
Date: Fri, 21 Oct 2005 15:32:49 -0600

On  Fri 10/21/2005 3:02 PM Jim Hyslop wrote:
>Martell, Larry wrote:
>> On Fri 10/21/2005 2:26 PM Jim Hyslop wrote:
>> I have never entered any CVS commands on the server machine (other
>> then the 1 attempt to add a file today).
> What was the pwd when you made that attempt?


>>>Check out a working copy into your home directory, and issue all CVS
>>>commands from within that working directory.
>> I want to add a new file - are you saying I need to check something out
>> before I can do that? What would I check out?
> You said you've been using Tortoise for over a year, so I'm presuming
> you are adding a new file to an existing project.

Yes and no ... here's the deal - the name of the project is aIRU. When the repository
was set up it was known there would be 4 modules - P4, DSP, host, and test, and
the person who set up the repository created these dirs on the server. P4, DSP, and
test are all windows modules and myself and other developers have been editing and
committing files to these modules with Tortoise. Today I started working on the
host module, which is on linux. So I created some source files and I want to add
those to the project.

> The process of adding a file to a project is the same, no matter where
> the repository is. On your Windows client using Tortoise CVS, you would
> check out the repository, add the file to your local working copy, then
> commit it.

I have never checked out the repository from my windows client. I just
created files, did a "CVS add", then a "CVS commit". If I need to edit
an existing file I do "CVS edit" then a "CVS commit"

> On the Linux box, the process is exactly the same: check out the
> repository into a work area, add the file, then commit it.

OK, I went to /home/martell/src and did "cvs co aIRU" This pulled all the
existing code  (for the P4, DSP, and test modules)  into my dir. There was nothing in the
host module on the repository, so nothing was checked out for that. Then I
issued the "cvs add *.c *.h Makefile" command and it worked. I followed this
with "cvs commit *.c *.h Makefile" which also worked. So now I'm good.
Thank you very much for the help.
> The work area
> *must not* be the same directory as the repository itself, unless you
> like playing Russian Roulette with your source code.

Yes, I realize that - this was never the case.

Thanks again!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]