[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: merging tarballs twice and having an issue.

From: Larry Jones
Subject: Re: merging tarballs twice and having an issue.
Date: Thu, 20 Oct 2005 15:49:37 -0400 (EDT)

Farshad Mahjoubi writes:
> We worked and added/upgraded these tarballs(JRE 1.5.04) as kv to a Branch
> and then we merge them once

I hope that was a typo and you actually used -kb rather than -kv.

> to the integration Branch. Now I have changed some of the permissions and
> and checked back in and committed
> my changes in to Integration_Branch.
> Another engineer tried to merge revision we are getting this error
> cvs update -d -P -j Integ_Branch jre1.5.0_04.tar.gz
> cvs update: file jre1.5.0_04.tar.gz exists, but has been added in revision
> Int_Branch
> Any idea what is happening here?

Just what it says -- one of the changes between the point where
Integ_Branch split off from the current branch and the tip of
Integ_Branch was the addition of that file, so the merge should create
it in the current directory, but it's already there, so it can't.  As
far as CVS knows, there is no relationship whatsoever between the file
that it's trying to create and the file that currently exists (except
that they have the same name), so it can't merge them.

-Larry Jones

This game lends itself to certain abuses. -- Calvin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]