[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Broken pipe with loginfo in a chroot jail

From: Maarten de Boer
Subject: Broken pipe with loginfo in a chroot jail
Date: Thu, 6 Nov 2003 17:34:22 +0100


I am running a CVS server in a chroot jail, and everything is working
okay, apart from one thing. We have been using a commitinfo script
for a long time with no problems, and now I wanted to add a loginfo
script as well. This however fails with a broken pipe.

If I run the same script from commitinfo, it works, and if I run the cvs
server normally (not in a jail), it also works. To test the later, I run
cvs on the cvs server itself (after I noticed that it failed running
through ssh): with the module i am testing checked out in the cvs-jail:

$ echo "some change" >> /cvs-jail/TestModule/test.txt
$ cvs -d /cvs-jail/mnt/cvsroot commit -m" " /cvs-jail/TestModule
cvs commit: Examining /cvs-jail/TestModule
Checking in /cvs-jail/TestModule/test.txt;
/cvs-jail/mnt/cvsroot/TestModule/test.txt,v  <--  test.txt
new revision: 1.49; previous revision: 1.48

$ echo "some change" >> /cvs-jail/TestModule/test.txt
$ chroot /cvs-jail/ cvs -d /mnt/cvsroot commit -m" " TestModule
cvs commit: Examining TestModule
Checking in TestModule/test.txt;
/mnt/cvsroot/TestModule/test.txt,v  <--  test.txt
new revision: 1.51; previous revision: 1.50
cvs [commit aborted]: received broken pipe signal

I have googled for this error, and I have found several mentions
of it, but no solution.

I can provide you with more information (running cvs with trace
output for example) if that would help.

Kind regards,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]