[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Broken pipe with loginfo in a chroot jail

From: Maarten De Boer
Subject: Re: Broken pipe with loginfo in a chroot jail
Date: Fri, 7 Nov 2003 00:13:48 +0000 (UTC)

> Most likely, the problem is that some command your script uses doesn't
> exist in your chroot jail -- perhaps even the script's interpreter.  I'd

It's not a script, it's a small executable - written in c.

> suggest running CVS with tracing enabled to see if that tells you
> anything, although I don't think it will.

Tried that. Does not tell me anything helpful...

> If not, add an echo into a
> file as the very first thing in the script to see if it's being run at
> all.

Tried fopen, fprintf, fclose. To no avail...

>  If it is, you can add more echos to see where it dies.  You could
> also try running the script manually inside the chroot jail.

Tried that. It works.

Has anybody here run loginfo's with a chrooted cvs server succesfully?
And could people with a chrooted cvs server test this behaviour?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]