[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Tagged branch not found

From: Vince Rice
Subject: RE: Tagged branch not found
Date: Fri, 5 Jul 2002 09:50:29 -0500

Well, as you might remember, I can't use anything past 1.11. :) (anything
past that is broken on Win32).  And I can guarantee that noone did this by
manually editing the files or using cvs admin.  What I think happened (but
haven't had time to test) is that they manually specifed a revision on the
commit, i.e. cvs -r or whatever).


-----Original Message-----
From: address@hidden [mailto:address@hidden Behalf Of
Eric Siegerman
Sent: Thursday, July 04, 2002 12:06 PM
To: address@hidden
Subject: Re: Tagged branch not found

On Wed, Jul 03, 2002 at 05:23:37PM -0500, Vince Rice wrote:
> Well, something is obviously wrong, because I have four *revisions*
> in that I can check out by specific revision number, e.g. (I've removed
> comments to protect the guilty. :) )
> revision
> date: 2002/06/26 19:44:05;  author: cvsuser;  state: Exp;  lines: +7 -8

For what it's worth -- i.e. not much, but it amuses me for some

Out of curiosity, I tried to reproduce this in 1.11.1p1 (I know
I've got 1.11.2 installed around here somewhere; now which box is
it on again?)

I succeeded:
        RCS file: /u03/home/erics/t/Repos/foo/a,v
        Working file: a
        head: 1.1
        locks: strict
        access list:
        symbolic names:
        keyword substitution: o
        total revisions: 2;     selected revisions: 2
        revision 1.1
        date: 2002/07/04 16:53:24;  author: erics;  state: Exp;
        branches:  1.1.0;
        *** empty log message ***
        date: 2002/07/04 16:54:54;  author: erics;  state: Exp;  lines: +1 -1


But to do it I had to manually edit the ,v file to give tag "b"
its bogus revision number

I tried to use cvs admin to create a branch with a .0.0 revision
number (using a different tag name to avoid a name collision):
        % cvs admin -nb2: a
        RCS file: /u03/home/erics/t/Repos/foo/a,v
        cvs [admin aborted]: revision `' does not exist

That was before I'd made the hand-edit and checked in revision
Interestingly enough, when I tried it again afterward, it worked!
        % cvs admin -nb2: a
        RCS file: /u03/home/erics/t/Repos/foo/a,v
        symbolic names:


|  | /\
|-_|/  >   Eric Siegerman, Toronto, Ont.        address@hidden
|  |  /
Anyone who swims with the current will reach the big music steamship;
whoever swims against the current will perhaps reach the source.
        - Paul Schneider-Esleben

Info-cvs mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]