[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Pserver & rsh problems with linux cvs talking to WinCVS :(

From: Chris Westcott
Subject: RE: Pserver & rsh problems with linux cvs talking to WinCVS :(
Date: Fri, 12 Jan 2001 15:11:23 -0000

Just beat you to it.  With much fiddling I managed to get it working.
Basically as you said the cvs root on the client should have had the linux 
path in it, not the Samba share.  I also copied a newer version of CVS onto 
the server.  I think the combination of the two sorted it.

Thanks for the info on the fact that CVS doesn't use UDP, I'll do a bit of 
cleaning up of that.

I am most appretiative of the help

-----Original Message-----
From:   Larry Jones [SMTP:address@hidden
Sent:   Friday, January 12, 2001 2:40 PM
To:     address@hidden
Cc:     address@hidden
Subject:        Re: Pserver & rsh problems with linux cvs talking to WinCVS :(

address@hidden writes:
> Firstly I have tried to setup pserver on the server.  My
> /etc/inet.conf file
> contains the following (all on a single line):
>       cvspserver stream tcp nowait root /usr/bin/cvs cvs
> --allow-root=/home/cvs pserver

You should have a -f in there along with --allow-root, although that
isn't the cause of your current problem.

> My /etc/services file contains the following lines:
>       cvspserver      2401/tcp                        # cvspserver
>       cvspserver      2401/udp                        # cvspserver

CVS doesn't use UDP so you can delete that entry if you like.

> I have setup a passwd file in $CVSROOT/CVSROOT as described in the
> docs and
> tried several combinations of a user named cvs_user with and without a
> password copied from /etc/shadow.  I assume that an entry in this file
> for the
> user with no password would be:
>       cvs_user:

What version of CVS is your server running?  Versions prior to 1.10.8
don't allow empty passwords.

> In WinCVS with the $CVSROOT address@hidden:\cvs\ where cvs_server
> is the
> linux box (setup with SAMBA) and cvs is a SAMBA share to the CVS_ROOT,
> ie
> /home/cvs.  When I try to connect from the client by doing a 'cvs
> login' I get
> the following error:
>       cvs [login aborted]: authorisation failed: server cvs_server rejected
> access

If you're using pserver, you don't need to mount the repository on the
client, you need to specify where it is on the server machine.  And it
needs to exactly match one of the server's --allow-root options.  So, it
should be:


And get used to using forward slashes in CVS commands instead of
backward slashes.  Although backward slashes seem to work much of the
time, they don't work completely right all of the time.

-Larry Jones

Whatever it is, it's driving me crazy! -- Calvin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]