[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Pserver & rsh problems with linux cvs talking to WinCVS :(

From: chris . westcott
Subject: Pserver & rsh problems with linux cvs talking to WinCVS :(
Date: Fri, 12 Jan 2001 10:38:01 -0000
User-agent: eGroups-EW/0.82

I've got a bit of a problem trying to set up CVS on SUSE Linux 7 as a
and using WinCVS as a client and wondered if anybody here may know
where I'm
going wrong.

Firstly I have tried to setup pserver on the server.  My
/etc/inet.conf file
contains the following (all on a single line):
        cvspserver stream tcp nowait root /usr/bin/cvs cvs
--allow-root=/home/cvs pserver

My /etc/services file contains the following lines:
        cvspserver      2401/tcp                        # cvspserver
        cvspserver      2401/udp                        # cvspserver
I am able to telnet to port 2401 OK receiving the message after typing
'test<CR>' upon connection:
        cvs [pserver aborted]: bad auth protocol start: test

I have setup a passwd file in $CVSROOT/CVSROOT as described in the
docs and
tried several combinations of a user named cvs_user with and without a
password copied from /etc/shadow.  I assume that an entry in this file
for the
user with no password would be:

In WinCVS with the $CVSROOT address@hidden:\cvs\ where cvs_server
is the
linux box (setup with SAMBA) and cvs is a SAMBA share to the CVS_ROOT,
/home/cvs.  When I try to connect from the client by doing a 'cvs
login' I get
the following error:
        cvs [login aborted]: authorisation failed: server cvs_server rejected

Any ideas???

Out of interest I tried to setup access via rsh instead.  In the home
directory I set up a .rhosts with the IP address of the client
machine.  I
have also ensured that hosts.equiv and hosts.allow contain the client
machine's IP address.

If I try to do a 'cvs status' whilst logged into 'chris' on Win client
connecting with address@hidden:\cvs\, as before I get the error:
        cvs status: cannot log in as local user 'Chris Westcott', remote user
        cvs [status aborted]: Permission denied by rshd

If I do the same as before but logged into Win as cvs_user I get the
        cvs status: warning: unrecognized response `Usage: cvs [cvs-options]
        command [command-options-and-arguments]' from cvs server
        cvs [status aborted]: reading from server: Connection reset by peer

Basically I don't mind whether I use rsh or pserver to access my box,
just as
long as it works (security isn't too much of an issue).

Any ideas as to where I am going wrong would be most gratefully

Many thanks in advance
  Chris Westcott

Software Engineer

reply via email to

[Prev in Thread] Current Thread [Next in Thread]