[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: CVS error when using repositories that include directories

From: Garth Winter Webb
Subject: Re: CVS error when using repositories that include directories
Date: Tue, 10 Oct 2000 13:57:26 -0700 (PDT)

If you get "Permission denied" then it definately is a permission problem
with one of the files or directories.  The permission problem does not
necessarily have to be in the repository.  Try updating or commiting a
single file at a time so you can narrow down the problem.  Additionally
use the '-t option to cvs to show a trace of CVS actions:

$ cvs -t update file.c

If the trace doesn't make the problem clear, post the trace output to the


On Tue, 10 Oct 2000, Bernhard Valenti wrote:

> hi,
> i have some problems with CVS and directories it seems.
> i setup 2 CVS repositories, everything imported fine.
> the problem only appears when doing remote operations ( cvs running on a 
> other machine then the repository is on, and it occurs with all three of 
> ssh/rsh/pserver )
> when i try update/commit from my working copy i get "Permission denied" ( it 
> updates some stuff before though ) there is no message on what Permission was 
> denied on.
> another thing is that it only happens when i try to update/commit in 
> directories that have another directory inside them ( which got checked out 
> fine including the contents)
> everything works fine when i update/commit from a working copy that resides 
> on the server with the repository (as the same user i use ssh/rsh/pserver 
> with though).
> so it cant be a filepermission problem.
> i quad checked all the permission in the working copies and in the 
> repositories
> i even tried to make the whole repository world writeable.
> didnt help. same problem.
> its definatly a problem with the dirs.. 
> but and dont see a way to debug cvs...
> except running truss on cvs update, which doesnt show anything weird
> ( i can mail the whole output on request )
> searching the mailing list archive i saw other people have the same problem.
> oh, and the repository runs on a freebsd 4.1 cvs version 1.10.7
> the clients i tried include freebsd 4.1 and debian linux woody. (both same 
> problems)
> again:
> its definiatly not a problem with the permission to the dirs/files.(maybe cvs 
> thinks that the directories are files and tries to open the directory as file 
> ??)
> regards, and hoping for quick help
> bernhard valenti
> _______________________________________________
> Info-cvs mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]