[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

CVS error when using repositories that include directories

From: Bernhard Valenti
Subject: CVS error when using repositories that include directories
Date: Tue, 10 Oct 2000 22:13:24 +0200
User-agent: Mutt/1.2.5i


i have some problems with CVS and directories it seems.

i setup 2 CVS repositories, everything imported fine.

the problem only appears when doing remote operations ( cvs running on a other 
machine then the repository is on, and it occurs with all three of 
ssh/rsh/pserver )

when i try update/commit from my working copy i get "Permission denied" ( it 
updates some stuff before though ) there is no message on what Permission was 
denied on.
another thing is that it only happens when i try to update/commit in 
directories that have another directory inside them ( which got checked out 
fine including the contents)

everything works fine when i update/commit from a working copy that resides on 
the server with the repository (as the same user i use ssh/rsh/pserver with 
so it cant be a filepermission problem.
i quad checked all the permission in the working copies and in the repositories
i even tried to make the whole repository world writeable.
didnt help. same problem.

its definatly a problem with the dirs.. 
but and dont see a way to debug cvs...
except running truss on cvs update, which doesnt show anything weird
( i can mail the whole output on request )

searching the mailing list archive i saw other people have the same problem.

oh, and the repository runs on a freebsd 4.1 cvs version 1.10.7
the clients i tried include freebsd 4.1 and debian linux woody. (both same 

its definiatly not a problem with the permission to the dirs/files.(maybe cvs 
thinks that the directories are files and tries to open the directory as file 

regards, and hoping for quick help

bernhard valenti

reply via email to

[Prev in Thread] Current Thread [Next in Thread]