[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Gnokii on Sharp Zaurus with Nokia 6150

From: Gernot Hillier
Subject: Re: Gnokii on Sharp Zaurus with Nokia 6150
Date: Sun, 29 Dec 2002 14:55:56 +0100
User-agent: KMail/1.4.3

Hash: SHA1


On Sunday 29 December 2002 14:29, Pawel Kot wrote:
> > I'm trying to get gnokii to work on my Sharp Zaurus running OpenZaurus
> > 3.0. I've read README-6110 and gnokii-ir-howto, but didn't get it to
> > work.
> Well, it is quite hard to say what's wrong not having access to the
> hardware. gnokii-ir-howto is written basing on real experience but with
> the pc, not Zaurus.

If nothing other helps and you like, I can try to give you a ssh login to the 
Zaurus for some time. But that would need me to reconfigure my firewall and I 
don't wanna do this if it's not absolutely necessary. So please let's try it 
via mail instead firstly...

> > But "gnokii --monitor" always tries to connect for a long time and
> > doesn't produce any output.
> Try gnokii --identify. It does a better connection test. If possible,

Same result. Sometimes I get "Telephone interface init failed! Quitting" 

> enable debug for the tests.

It's necessary to recompile for this, right? I've no idea how to do this 
currently (cross-compiling...) but I can try to do it if you don't have 
another idea...

> > # gnokii --monitor
> > GNOKII Version 0.4.3
> > <now wait forever :-( >
> And perhaps upgrade to the latest CVS.

Same problem as above...

> Maybe that's serial port incorrect setting. Any debug output from all
> three setups would be usefull to resolve the issue.

Is there a way to get any helpful output for you without recompiling?

> Yes, infrared is the correct one. My guess is that you need:
> connection = infrared
> port = /dev/ttyS1
> if you have the serial port in the Zaurus and
> connection = infrared
> port = /dev/ttyS0
> if you don't have one.

Both give me "Telephone interface init failed! Quitting".

> > I'm able to unload ircomm-tty and ircomm and sa1100_ir, but this doesn't
> > help either. I stopped the GUI but this doesn't help, too....
> You need to unload irda as well.

Naturally, just forgot this in my list. Have unloaded this, too, but doesn't 

BTW: I see 

COLLIE serial driver version 1.3
ttyS0 on SA1100 UART3 (irq 17)
ttyS1 on SA1100 UART1 (irq 15)touch adj= 17941,25486,-1441792,-3473408 

in dmesg output. Does this help you? Are these unnormal irq values a problem?

The PDA has one serial connector and one IR port. But I fave no idea what's 
ttyS0 and what ttyS1, so I always tried both...

- -- 

"Der Horizont vieler Menschen ist ein Kreis mit Radius Null - und das nennen 
sie ihren Standpunkt." (A. Einstein)
Version: GnuPG v1.0.7 (GNU/Linux)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]