[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Gnokii on Sharp Zaurus with Nokia 6150

From: Pawel Kot
Subject: Re: Gnokii on Sharp Zaurus with Nokia 6150
Date: Sun, 29 Dec 2002 14:29:09 +0100 (CET)

On Sun, 29 Dec 2002, Gernot Hillier wrote:

Hi Gernot,

> I'm trying to get gnokii to work on my Sharp Zaurus running OpenZaurus 3.0.
> I've read README-6110 and gnokii-ir-howto, but didn't get it to work.

Well, it is quite hard to say what's wrong not having access to the
hardware. gnokii-ir-howto is written basing on real experience but with
the pc, not Zaurus.

> If I enable IRDA and IRDA-discovery on my Zaurus, a small message box pops up
> telling my a "Nokie 6100" has been found, so something seems to work.

You just know that both irda in Zaurus and in the phone work. But gnokii
needs own infrared driver to let 6150 work over this connection. It will
NOT work if irda is enabled in the Linux kernel.

> But "gnokii --monitor" always tries to connect for a long time and doesn't
> produce any output.

Try gnokii --identify. It does a better connection test. If possible,
enable debug for the tests.

> # gnokii --monitor
> GNOKII Version 0.4.3
> <now wait forever :-( >

And perhaps upgrade to the latest CVS.

> As far as I understood it I must use gnokii and not the IRDA drivers from
> Linux as the Nokia 6150 doesn't support a real IRDA-protocol, right?

Yes. Correct. Well, Nokia 6150 supports just a part of the IrDA protocol
as it comes from our experience, but noone was able to make use of this.
So you need to disable IrDA support in the Linux kernel at all.

> I tried to use
> port = /dev/ircomm
> or
> port = /dev/ttyS0
> or
> port = /dev/ttyS1

Maybe that's serial port incorrect setting. Any debug output from all
three setups would be usefull to resolve the issue.

> in my ~/.gnokiirc but nothing helps. I also tried
> connection = infrared
> or
> connection = irda
> BTW: does this make any difference?

Yes, infrared is the correct one. My guess is that you need:
connection = infrared
port = /dev/ttyS1
if you have the serial port in the Zaurus and
connection = infrared
port = /dev/ttyS0
if you don't have one.

I belive that you have serial port support in the Linux kernel.

> Module                  Size  Used by
> ircomm-tty             23664   0  (autoclean)
> ircomm                 10336   0  (autoclean) [ircomm-tty]
> sa1100_ir               7088   1  (autoclean)
> irda                  103440   0  (autoclean) [ircomm-tty ircomm sa1100_ir]

All above need to be unloaded.

> I'm able to unload ircomm-tty and ircomm and sa1100_ir, but this doesn't help
> either. I stopped the GUI but this doesn't help, too....

You need to unload irda as well.

mailto:address@hidden :: mailto:address@hidden :: Kernel Traffic po polsku

reply via email to

[Prev in Thread] Current Thread [Next in Thread]