[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnewsense-dev] Xulrunner freedom bug: how to apply patch?

From: Christophe Jarry
Subject: Re: [Gnewsense-dev] Xulrunner freedom bug: how to apply patch?
Date: Wed, 8 Dec 2010 13:03:05 +0100

I tried to solve xulrunner freedom bug, but have some problems.

First, I used iceweasel 3.5.8 from Lenny Backports
( and
-the changes Robert Millan made in our current version of Xulrunner,
-the bug fix.

I discovered there was no rule to build xulrunner from this version of
iceweasel under the "debian" directory and I am not able to do all that
work by myself.

So I looked for the latest version of Lenny Backport's Xulrunner
prepared by the maintainers at this is
xulrunner- (see

I applied the changes made by Robert and the bug fix.

When I `dpkg-buildpackage -rfakeroot -us -uc', I have a lot of
dependancy problems. I think those can only be solved by basing metad
entirely upon current version of Lenny Backport, which sounds unlikely.

So where should I go from here? Is it better to:
-try packaging Lenny's version of xulrunner with bug fix?
-apply the fix to the metad's version of xulrunner? (Seems the best
option to me.)
-wait for Parkes release then fix the bug in it?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]