[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gcl-devel] Re: gcl 2.5.0 on Solaris: no joy

From: Gordon Shaw Novak
Subject: [Gcl-devel] Re: gcl 2.5.0 on Solaris: no joy
Date: Fri, 23 Aug 2002 16:31:30 -0500

> It looks like make on Solaris doesn't like the - in -include makedefs .
> Removing the - moved the error (to a similar spot in the next makefile).

man make on Solaris says the following (both under Special Characters):

     include filename
           If the word include appears as the first seven letters
           of  a  line  and  is  followed  by a SPACE or TAB, the
           string that follows is taken as a filename to interpo-
           late  at  that  line. include files can be nested to a
           depth of no more than about 16.

     -     make ignores any nonzero error code returned by a com-
           mand  line  for which the first non-TAB character is a
           `-'.  This character is not passed  to  the  shell  as
           part  of  the  command  line. make normally terminates
           when a command returns nonzero status, unless  the  -i
           or -k options, or the .IGNORE: special-function target
           is in effect.

Perhaps they have some crude test for 'include' in the first 7 columns
before they test for the -.  At any rate, -include seems to cause
an error.

I removed the - from the includes in all the makefiles and tried the
make.  It still doesn't succeed, but goes a lot farther.
I'll investigate the remaining problem further.

Many thanks, Gordon

reply via email to

[Prev in Thread] Current Thread [Next in Thread]