discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gnustep-base tests


From: Eric Heintzmann
Subject: Re: gnustep-base tests
Date: Wed, 11 May 2016 10:22:25 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Icedove/38.7.2



Le 11/05/2016 08:58, Richard Frith-Macdonald a écrit :
On 10 May 2016, at 23:15, Eric Heintzmann <address@hidden> wrote:



Le 10/05/2016 11:41, Richard Frith-Macdonald a écrit :
On the one hand, the particular number format stuff is rarely used, so a bug 
there may not be important (and may depend on the particular ICU library 
shipped on the system).
Well I ve done some tests and this particular problem is common to debian 
testing (stretch)  and unstable (sid) and Ubuntu 16.04 too...
On the other, we really want to fix *any* failure of the regression tests.
Does the same problem occur with gnustep-base from svn trunk?
Can you get a stack trace of the crash?

Well I ve tried to use gnustep-make 2.6.6-3 to build gnustep-base 1.24.9 and 
the regrssesion test ar ok !!
It seem the bug is in gnustep-make 2.6.8 (or in the packaging)
While I don't remember anything significant changng, I guess there might have 
been a change in the test framework code which could have exposed a bug in the 
library  not noticed in the older version or something.  I think we need stack 
traces from gdb (ie full symbolic information) to find out where the issue is.  
It's also strange that nobody else is seeing it.
Just a precision:
I run 'make check', after 'make' but before 'make install'



reply via email to

[Prev in Thread] Current Thread [Next in Thread]