[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-gsl] [bug #27515] install-sh is broken with current automake

From: Brian Gough
Subject: [Bug-gsl] [bug #27515] install-sh is broken with current automake
Date: Thu, 24 Sep 2009 10:29:59 +0000
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv: Gecko/2009020410 Fedora/3.0.6-1.fc9 Firefox/3.0.6


                 Summary: install-sh is broken with current automake
                 Project: GNU Scientific Library
            Submitted by: bjg
            Submitted on: Thu 24 Sep 2009 11:29:57 AM BST
                Category: Build
                Severity: 4 - Important
        Operating System: 
                  Status: Confirmed
             Assigned to: None
             Open/Closed: Open
                 Release: 1.13
         Discussion Lock: Any



From: Alexander Belikoff <address@hidden>
To: address@hidden
Subject: [Bug-gsl] GSL installation bug
Date: Wed, 23 Sep 2009 15:20:15 -0400

Hello – I’m trying to install GSL on Solaris 10 and I’ve run into an
installation procedure bug. At least in ./matrix directory the install
command is:

.././install-sh -c -m 644 gsl_matrix.h gsl_matrix_char.h
gsl_matrix_complex_double.h gsl_matrix_complex_float.h
gsl_matrix_complex_long_double.h gsl_matrix_double.h gsl_matrix_float.h
gsl_matrix_int.h gsl_matrix_long.h gsl_matrix_long_double.h
gsl_matrix_short.h gsl_matrix_uchar.h gsl_matrix_uint.h gsl_matrix_ulong.h
gsl_matrix_ushort.h TARGET_DIR

However, install-sh is coded in such a way that it only uses the first
non-option argument as a source and the last one as destination quietly
ignoring the rest of them. This results in only gsl_matrix.h being installed
and all other headers quietly ignored.

I'll try to hack a patch overnight and send it over to you guys.

-- Sasha
Bug-gsl mailing list

From: Peter Johansson <address@hidden>
To: Alexander Belikoff <address@hidden>
Cc: address@hidden
Subject: Re: [Bug-gsl] GSL installation bug
Date: Thu, 24 Sep 2009 00:05:31 -0400

Hello Sasha,

please keep bug-gsl in cc (especially since I'm just a user and not the 

Alexander Belikoff wrote:
> Hello Peter - thanks for the quick response. Cannot check right now, 
> will do tomorrow morning. GSL itself was downloaded as a .tgz package 
> from GNU FTP server (version 1.13). What install-sh does, is the 
> following: the moment it finds a non-option argument it assigns it to 
> *src* variable. Next time it finds a non-option argument, given that 
> *$src* is non-empty, it assigns it to *dst*. As a result, after 
> processing the command-line arguments, *$src* is the first non-option 
> arg, and *$dst* is the last one with everything in between ignored.
I downloaded the latest gsl (1.13) and indeed the behavior of install-sh 
is sub-optimal. When I previously claimed that install-sh worked as 
expected for me that was based on an install-sh that comes with automake 
1.11 (script version 2009-04-28.21). That version of install-sh differs 
significantly from the one in gsl 1.13. It seems like the install-sh has 
not been updated when the maintainer has updated his automake. The 
Makefile.ins that come in gsl 1.13 are created by automake 1.11 but 
install-sh is probably an older version. In order to update install-sh 
(and friends) one needs to (as a maintainer) call automake with the 
--force switch. I noticed that the autogen.sh script in the git 
repository calls automake without the --force switch, which might 
explain why the files have never been updated.

> I've fixed it for my installation by lifting install-sh from another 
> package and putting it in place of the one in GSL.
Seems like a good workaround.
> Anyway, I'll provide more info tomorrow...


Bug-gsl mailing list


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]