[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-gsl] GSL installation bug

From: Peter Johansson
Subject: Re: [Bug-gsl] GSL installation bug
Date: Thu, 24 Sep 2009 00:05:31 -0400
User-agent: Thunderbird (Macintosh/20090302)

Hello Sasha,

please keep bug-gsl in cc (especially since I'm just a user and not the maintainer)

Alexander Belikoff wrote:
Hello Peter - thanks for the quick response. Cannot check right now, will do tomorrow morning. GSL itself was downloaded as a .tgz package from GNU FTP server (version 1.13). What install-sh does, is the following: the moment it finds a non-option argument it assigns it to *src* variable. Next time it finds a non-option argument, given that *$src* is non-empty, it assigns it to *dst*. As a result, after processing the command-line arguments, *$src* is the first non-option arg, and *$dst* is the last one with everything in between ignored.
I downloaded the latest gsl (1.13) and indeed the behavior of install-sh is sub-optimal. When I previously claimed that install-sh worked as expected for me that was based on an install-sh that comes with automake 1.11 (script version 2009-04-28.21). That version of install-sh differs significantly from the one in gsl 1.13. It seems like the install-sh has not been updated when the maintainer has updated his automake. The Makefile.ins that come in gsl 1.13 are created by automake 1.11 but install-sh is probably an older version. In order to update install-sh (and friends) one needs to (as a maintainer) call automake with the --force switch. I noticed that the autogen.sh script in the git repository calls automake without the --force switch, which might explain why the files have never been updated.

I've fixed it for my installation by lifting install-sh from another package and putting it in place of the one in GSL.
Seems like a good workaround.

Anyway, I'll provide more info tomorrow...


reply via email to

[Prev in Thread] Current Thread [Next in Thread]