[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [patch #3946] Add make support for windows PE resources

From: Sheldon Gill
Subject: Re: [patch #3946] Add make support for windows PE resources
Date: Sun, 17 Jul 2005 11:32:59 +0800
User-agent: Mozilla Thunderbird 1.0 (Windows/20041206)

Nicola Pero wrote:

I did get confused. I changed RC_FILES to WINRES_FILES and RCFLAGS to WINRESFLAGS *after* I submitted the patch, not before. (Note, no 'D')

Good point about the 'D'.  The name needs more thinking :-)

Probably you're right and it should be WINRES_FILES rather than WINDRES_FILES.

hmmm .... I tried to look on the web for how Microsoft calls such a file ... it looks like it would be called a "resource-definition script (.rc file)"

The compiled resource thing goes back to Windows version 1. They didn't have resource forks for FAT16 but wanted it all in a single executable just like Word on "that other platform"...

Nonmenclature has varied somewhat, as is typical with MS. They've never been very good at tying down technical definitions. Anyway, it was originally a "resource script" or "resource script file" which you used to create a "compiled resource (file)" which was linked into your executable. These scripts contained "Menu resource definition scripts" and "Dialog resource definition scripts" etc.

Remember also that many a DOS/Win programmer calls them "eksey files" instead of programs or applications.

On the Delphi web site they call it "a resource script file", and they have the 'Borland Resource Compiler'. When they get down to real business they seem to start referring to it simply as the '.RC file' though.

Actually everyone seems to be calling it an '.rc file' after having explained what it is.

Pretty much. If you get the properties on such a file you'll find it described "Resource script".

So I'm honestly tempted by xxx_WINDOWS_RC_FILES. It's a bit longer to write, but looks like the most expressive / easy to understand, both for Windows programmers (who understand it's an .rc file), and for non-Windows programmers (who understand it's a Windows-only thing).


So my current inclination (totally open to discussion) is:

 xxx_WINDOWS_RC_FILES for the files,
 WINDRES_FLAGS for the flags to pass to the 'windres' program

Sounds reasonable ?  Any comments ?

Sounds perfectly reasonable. Perhaps shorten it to _WIN_RC?

The only issue with this solution is that the FLAGS variable is named rather differently to the others. As long as the docs are clear I don't see any problem. I have, btw, some -make docs to contribute too.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]