bug-cvs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: FYI: CVS Import Bug - Please Respond


From: Jim Hyslop
Subject: Re: FYI: CVS Import Bug - Please Respond
Date: Mon, 08 Aug 2005 11:50:52 -0400
User-agent: Mozilla Thunderbird 1.0.2 (Windows/20050317)

[note: removed 'address@hidden' from recipient list]

Oproescu Bogdan (KTXA 3) wrote:
Hello bug-cvs mailing list, We still have the problem that I described below on July 29, and namely the corrupted CVS Files that result for our parallel CVS Imports into the SAME Module and Repository pair on our CVS Central Server.

First of all, thank you for your patience. You'd be amazed at the number of people who re-post their questions after only five minutes :=)

Please read this message below and let us know if you can resolve this CVS Bug and also send us an estimate of the effort and length of time required to solve this.
[...]
We are working with CVS at Credit Suisse and we have noticed what we think is a CVS Bug: when we import a Module repeatedly, call it TestModule for the sake of our discussion, into some Repository on our central CVS Server, call it TestRepository, CVS works correctly. However, when we introduce the 2nd to Nth CVS Clients into this picture, and keep importing this same module TestModule into this same repository TestRepository, from possibly different build servers, we get the following errors: 1. Error Type 1:
     [cvs] cvs import: Importing /rep/fnagl/FNDB/agl/FNDB
     [cvs] cvs [import aborted]: cannot rename file 
/rep/fnagl/FNDB/agl/FNDB/,FNDB_T.jar, to /rep/fnagl/FNDB/agl/FNDB/FNDB_T.jar,v: 
No such file or directory
     [cvs] U FNDB/agl/FNDB/component.xml
     [cvs] U FNDB/agl/FNDB/FNDB_T_src.jar
     [cvs] U FNDB/agl/FNDB/FNDB_src.jar
     [cvs] U FNDB/agl/FNDB/build.xml
     [cvs] U FNDB/agl/FNDB/qmbbuildstatus.xml

OR: 2. Error Type 2: cvs [checkout aborted]: unexpected '\x45' reading revision number in RCS file /rep/fnagl/FNORB/agl/FNORB/FNORB.jar,v

OK, some questions first off.

Is it only the file FNDB_T.jar that causes problems, or are there other files that cause these errors as well?

Which version of the client and the server are you using ("cvs version" will report the server version)?

One possibility is that the .jar files are not being flagged as binary. Do you have an entry in $CVSROOT/CVSROOT/cvswrappers for *.jar? If not, you can specify the wrappers option in the import command using 'cvs import -W'. Unfortunately, the manual (http://ximbiot.com/cvs/manual/cvs-1.11.20/cvs_16.html#SEC140) is a little fuzzy on exactly how you specify -W, and I've never used it, so you may have to experiment a little to find the correct syntax.

--
Jim





reply via email to

[Prev in Thread] Current Thread [Next in Thread]