[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [AUCTeX] reftex-label-alist for ctable package

From: Tassilo Horn
Subject: Re: [AUCTeX] reftex-label-alist for ctable package
Date: Thu, 02 Aug 2012 15:20:45 +0200
User-agent: Gnus/5.130006 (Ma Gnus v0.6) Emacs/24.1.50 (gnu/linux)

Michael Bach <address@hidden> writes:

>> And to absolutely sure that nothing interferes, here's a minimal
>> working recipe starting with emacs -Q which works just fine for me.
>>    $ emacs -Q foo.tex # contains ctables, lstlisting with label={x}
>>    M-x reftex-mode    ;; enable reftex-mode
>>    C-c =              ;; shows TOC buffer
>>    l                  ;; enables the display of labels
> This got me curious and I tried the TOC buffer via C-c = and after pressing
> "l", I got the labels! It also works with `label = ...', no need to
> label={x}'. Do you mean that only for lstlistings one needs `label={x}'?

No, both forms are allowed everywhere.  Just wanted to test both of

> I do see this too now.


>> If I do `C-c )' in the foo.tex file and select SPC to show all
>> labels, I get a similar *RefTeX Select* buffer.
> Again, doing the SPC in the *RefTeX Select* buffer also gives me the
> labels.

Very good.

> I tested more and found that I always used the C-c ) after a literal
> `table' so the auto match function catapulted me into a *RefTeX
> Select* buffer that listed only table labels.  Similarly, when I tried
> it at another position I always, as a habit, did C-c ) followed by `t'
> for table. And there the labels do *NOT* show up for me...

Oh, right. :-(

> So there seems to be something awry with the way the ?t gets used
> inside the alist for ctable in reftex-label-alist-builtin, doesn't it?

Indeed, and ?l doesn't even occur as possible selection, although
there's a listing in the file...

I'll look into that, but don't hold your breath.  I'm in holidays from
Friday on.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]