[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [AUCTeX] reftex-label-alist for ctable package

From: Michael Bach
Subject: Re: [AUCTeX] reftex-label-alist for ctable package
Date: Thu, 02 Aug 2012 14:38:28 +0200
User-agent: Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20120713 Thunderbird/14.0

Hi Tassilo,

Anyway, I tried it again today on my home box with the exact recipe
from my previous post - still no luck. Maybe someone is willing to
help and could also test this patch?

If not, you could also try a windows snapshot build from

Right now, the most recent version there doesn't yet contain my patches.
Maybe there's a new build in a few days.  The revision number must be
r109239 or higher, then it contains my patches and should work out of
the box.

And to absolutely sure that nothing interferes, here's a minimal working
recipe starting with emacs -Q which works just fine for me.

   $ emacs -Q foo.tex # contains ctables, lstlisting with label={x}
   M-x reftex-mode    ;; enable reftex-mode
   C-c =              ;; shows TOC buffer
   l                  ;; enables the display of labels

This got me curious and I tried the TOC buffer via C-c = and after pressing "l", I got the labels! It also works with `label = ...', no need to `label={x}'. Do you mean that only for lstlistings one needs `label={x}'?

Now I see something like

--8<---------------cut here---------------start------------->8---
TABLE-OF-CONTENTS on ~/tmp/foo.tex
SPC=view TAB=goto RET=goto+hide [q]uit [r]escan [l]abels [f]ollow [x]r [?]Help
      1 bla
        1.1 blub
      2 goo
--8<---------------cut here---------------end--------------->8---

Before the `l' command, only the sections are shown.

I do see this too now.

If I do `C-c )' in the foo.tex file and select SPC to show all labels, I
get a similar *RefTeX Select* buffer.

Again, doing the SPC in the *RefTeX Select* buffer also gives me the labels.

I tested more and found that I always used the C-c ) after a literal `table' so the auto match function catapulted me into a *RefTeX Select* buffer that listed only table labels. Similarly, when I tried it at another position I always, as a habit, did C-c ) followed by `t' for table. And there the labels do *NOT* show up for me...

So there seems to be something awry with the way the ?t gets used inside the alist for ctable in reftex-label-alist-builtin, doesn't it?

Thanks again for your time Tassilo!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]