[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v2 05/11] target/alpha, hppa: Remove unused parent_reset fields
From: |
Peter Maydell |
Subject: |
[PATCH v2 05/11] target/alpha, hppa: Remove unused parent_reset fields |
Date: |
Fri, 30 Aug 2024 15:58:06 +0100 |
The Alpha and HPPA CPU class structs include a 'parent_reset'
field which is never used; delete them.
(These targets don't seem to implement reset at all; if they did they
should do it using the three-phase reset mechanism, which uses a
'ResettablePhases parent_phases' field instead of the old
'DeviceReset parent_reset' field.)
Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
Reviewed-by: Richard Henderson <richard.henderson@linaro.org>
---
target/alpha/cpu.h | 2 --
target/hppa/cpu.h | 2 --
2 files changed, 4 deletions(-)
diff --git a/target/alpha/cpu.h b/target/alpha/cpu.h
index f9e2ecb90ab..3556d3227f8 100644
--- a/target/alpha/cpu.h
+++ b/target/alpha/cpu.h
@@ -267,7 +267,6 @@ struct ArchCPU {
/**
* AlphaCPUClass:
* @parent_realize: The parent class' realize handler.
- * @parent_reset: The parent class' reset handler.
*
* An Alpha CPU model.
*/
@@ -275,7 +274,6 @@ struct AlphaCPUClass {
CPUClass parent_class;
DeviceRealize parent_realize;
- DeviceReset parent_reset;
};
#ifndef CONFIG_USER_ONLY
diff --git a/target/hppa/cpu.h b/target/hppa/cpu.h
index 2bcb3b602b8..d34710f0aa9 100644
--- a/target/hppa/cpu.h
+++ b/target/hppa/cpu.h
@@ -281,7 +281,6 @@ struct ArchCPU {
/**
* HPPACPUClass:
* @parent_realize: The parent class' realize handler.
- * @parent_reset: The parent class' reset handler.
*
* An HPPA CPU model.
*/
@@ -289,7 +288,6 @@ struct HPPACPUClass {
CPUClass parent_class;
DeviceRealize parent_realize;
- DeviceReset parent_reset;
};
#include "exec/cpu-all.h"
--
2.34.1
- [PATCH v2 00/11] s390: Convert virtio-ccw, cpu to three-phase reset, and followup cleanup, Peter Maydell, 2024/08/30
- [PATCH v2 01/11] hw/s390/ccw-device: Convert to three-phase reset, Peter Maydell, 2024/08/30
- [PATCH v2 02/11] hw/s390/virtio-ccw: Convert to three-phase reset, Peter Maydell, 2024/08/30
- [PATCH v2 04/11] hw: Remove device_class_set_parent_reset(), Peter Maydell, 2024/08/30
- [PATCH v2 05/11] target/alpha, hppa: Remove unused parent_reset fields,
Peter Maydell <=
- [PATCH v2 06/11] hw: Define new device_class_set_legacy_reset(), Peter Maydell, 2024/08/30
- [PATCH v2 03/11] target/s390: Convert CPU to Resettable interface, Peter Maydell, 2024/08/30
- [PATCH v2 08/11] hw: Rename DeviceClass::reset field to legacy_reset, Peter Maydell, 2024/08/30
- [PATCH v2 10/11] hw/core/qdev: Simplify legacy_reset handling, Peter Maydell, 2024/08/30
- [PATCH v2 09/11] hw: Remove device_phases_reset(), Peter Maydell, 2024/08/30
- [PATCH v2 11/11] hw/core/resettable: Remove transitional_function machinery, Peter Maydell, 2024/08/30
- [PATCH v2 07/11] hw: Use device_class_set_legacy_reset() instead of opencoding, Peter Maydell, 2024/08/30