qemu-commits
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-commits] [qemu/qemu] 618487: monitor: Trim some trailing space fro


From: Richard Henderson
Subject: [Qemu-commits] [qemu/qemu] 618487: monitor: Trim some trailing space from human-reada...
Date: Mon, 01 Nov 2021 06:45:14 -0700

  Branch: refs/heads/staging
  Home:   https://github.com/qemu/qemu
  Commit: 61848717d639446b58b069e480739a757d74813d
      
https://github.com/qemu/qemu/commit/61848717d639446b58b069e480739a757d74813d
  Author: Markus Armbruster <armbru@redhat.com>
  Date:   2021-10-31 (Sun, 31 Oct 2021)

  Changed paths:
    M monitor/hmp-cmds.c
    M target/i386/cpu-dump.c
    M target/i386/cpu.c
    M target/ppc/cpu_init.c
    M target/s390x/cpu_models.c
    M target/xtensa/mmu_helper.c

  Log Message:
  -----------
  monitor: Trim some trailing space from human-readable output

I noticed -cpu help printing enough trailing spaces to make the output
at least 84 characters wide.  Looks ugly unless the terminal is wider.
Ugly or not, trailing spaces are stupid.

The culprit is this line in x86_cpu_list_entry():

    qemu_printf("x86 %-20s  %-58s\n", name, desc);

This prints a string with minimum field left-justified right before a
newline.  Change it to

    qemu_printf("x86 %-20s  %s\n", name, desc);

which avoids the trailing spaces and is simpler to boot.

A search for the pattern with "git-grep -E '%-[0-9]+s\\n'" found a few
more instances.  Change them similarly.

Signed-off-by: Markus Armbruster <armbru@redhat.com>
Reviewed-by: Richard Henderson <richard.henderson@linaro.org>
Acked-by: Greg Kurz <groug@kaod.org>
Reviewed-by: Philippe Mathieu-Daudé <philmd@redhat.com>
Acked-by: Max Filippov <jcmvbkbc@gmail.com>
Message-Id: <20211009152401.2982862-1-armbru@redhat.com>
Signed-off-by: Laurent Vivier <laurent@vivier.eu>


  Commit: 3a23a0c06171c97e7327dd75ae5503f2e38fe749
      
https://github.com/qemu/qemu/commit/3a23a0c06171c97e7327dd75ae5503f2e38fe749
  Author: Yanan Wang <wangyanan55@huawei.com>
  Date:   2021-10-31 (Sun, 31 Oct 2021)

  Changed paths:
    M hw/core/machine.c

  Log Message:
  -----------
  hw/core/machine: Add the missing delimiter in cpu_slot_to_string()

The expected output string from cpu_slot_to_string() ought to be
like "socket-id: *, die-id: *, core-id: *, thread-id: *", so add
the missing ", " before "die-id". This affects the readability
of the error message.

Fixes: 176d2cda0d ("i386/cpu: Consolidate die-id validity in smp context")
Signed-off-by: Yanan Wang <wangyanan55@huawei.com>
Reviewed-by: Laurent Vivier <laurent@vivier.eu>
Message-Id: <20211008075040.18028-1-wangyanan55@huawei.com>
Signed-off-by: Laurent Vivier <laurent@vivier.eu>


  Commit: 11f976adeeb7ff0799f972a48d02f66015f53416
      
https://github.com/qemu/qemu/commit/11f976adeeb7ff0799f972a48d02f66015f53416
  Author: Philippe Mathieu-Daudé <f4bug@amsat.org>
  Date:   2021-10-31 (Sun, 31 Oct 2021)

  Changed paths:
    M MAINTAINERS

  Log Message:
  -----------
  MAINTAINERS: Split HPPA TCG vs HPPA machines/hardware

Hardware emulated models don't belong to the TCG MAINTAINERS
section. Move them to the 'HP-PARISC Machines' section.

Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
Reviewed-by: Richard Henderson <richard.henderson@linaro.org>
Reviewed-by: Helge Deller <deller@gmx.de>
Message-Id: <20211004083835.3802961-1-f4bug@amsat.org>
Signed-off-by: Laurent Vivier <laurent@vivier.eu>


  Commit: 5d2bd73588d14b5868129ace9c7912a777f06753
      
https://github.com/qemu/qemu/commit/5d2bd73588d14b5868129ace9c7912a777f06753
  Author: Philippe Mathieu-Daudé <f4bug@amsat.org>
  Date:   2021-10-31 (Sun, 31 Oct 2021)

  Changed paths:
    M hw/input/lasips2.c

  Log Message:
  -----------
  hw/input/lasips2: Fix typos in function names

Artist is another device, this one is the Lasi PS/2.
Rename the functions accordingly.

Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
Reviewed-by: Damien Hedde <damien.hedde@greensocs.com>
Message-Id: <20210920064048.2729397-2-f4bug@amsat.org>
Signed-off-by: Laurent Vivier <laurent@vivier.eu>


  Commit: 2b1b5585b7b0ef7aca46543a40623cd8420e6cf2
      
https://github.com/qemu/qemu/commit/2b1b5585b7b0ef7aca46543a40623cd8420e6cf2
  Author: Philippe Mathieu-Daudé <f4bug@amsat.org>
  Date:   2021-10-31 (Sun, 31 Oct 2021)

  Changed paths:
    M hw/input/lasips2.c
    M include/hw/input/lasips2.h

  Log Message:
  -----------
  hw/input/lasips2: Move LASIPS2State declaration to 'hw/input/lasips2.h'

We want to use the OBJECT_DECLARE_SIMPLE_TYPE() macro to QOM'ify
this device in the next commit. To make its review simpler, as a
first step move the LASIPS2State and LASIPS2Port declarations to
'hw/input/lasips2.h'

Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
Reviewed-by: Damien Hedde <damien.hedde@greensocs.com>
Message-Id: <20210920064048.2729397-3-f4bug@amsat.org>
Signed-off-by: Laurent Vivier <laurent@vivier.eu>


  Commit: c3f93230df9ad1d3260f03655faa8f9f23c90a52
      
https://github.com/qemu/qemu/commit/c3f93230df9ad1d3260f03655faa8f9f23c90a52
  Author: Philippe Mathieu-Daudé <f4bug@amsat.org>
  Date:   2021-10-31 (Sun, 31 Oct 2021)

  Changed paths:
    M hw/hppa/lasi.c
    M hw/input/lasips2.c
    M include/hw/input/lasips2.h

  Log Message:
  -----------
  hw/input/lasips2: QOM'ify the Lasi PS/2

Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
Reviewed-by: Damien Hedde <damien.hedde@greensocs.com>
Message-Id: <20210920064048.2729397-4-f4bug@amsat.org>
Signed-off-by: Laurent Vivier <laurent@vivier.eu>


  Commit: 5f40d5e7944299a7e649b94025fe4f43f7bf9ec1
      
https://github.com/qemu/qemu/commit/5f40d5e7944299a7e649b94025fe4f43f7bf9ec1
  Author: Richard Henderson <richard.henderson@linaro.org>
  Date:   2021-11-01 (Mon, 01 Nov 2021)

  Changed paths:
    M MAINTAINERS
    M hw/core/machine.c
    M hw/hppa/lasi.c
    M hw/input/lasips2.c
    M include/hw/input/lasips2.h
    M monitor/hmp-cmds.c
    M target/i386/cpu-dump.c
    M target/i386/cpu.c
    M target/ppc/cpu_init.c
    M target/s390x/cpu_models.c
    M target/xtensa/mmu_helper.c

  Log Message:
  -----------
  Merge remote-tracking branch 
'remotes/vivier/tags/trivial-branch-for-6.2-pull-request' into staging

Trivial patches branch pull request 20211101

# gpg: Signature made Mon 01 Nov 2021 04:27:02 AM EDT
# gpg:                using RSA key CD2F75DDC8E3A4DC2E4F5173F30C38BD3F2FBE3C
# gpg:                issuer "laurent@vivier.eu"
# gpg: Good signature from "Laurent Vivier <lvivier@redhat.com>" [full]
# gpg:                 aka "Laurent Vivier <laurent@vivier.eu>" [full]
# gpg:                 aka "Laurent Vivier (Red Hat) <lvivier@redhat.com>" 
[full]

* remotes/vivier/tags/trivial-branch-for-6.2-pull-request:
  hw/input/lasips2: QOM'ify the Lasi PS/2
  hw/input/lasips2: Move LASIPS2State declaration to 'hw/input/lasips2.h'
  hw/input/lasips2: Fix typos in function names
  MAINTAINERS: Split HPPA TCG vs HPPA machines/hardware
  hw/core/machine: Add the missing delimiter in cpu_slot_to_string()
  monitor: Trim some trailing space from human-readable output

Signed-off-by: Richard Henderson <richard.henderson@linaro.org>


Compare: https://github.com/qemu/qemu/compare/af531756d255...5f40d5e79442



reply via email to

[Prev in Thread] Current Thread [Next in Thread]