[Top][All Lists]
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Pspp-commits] [SCM] GNU PSPP branch, master, updated. v0.7.9-298-gd331e
From: |
Ben Pfaff |
Subject: |
[Pspp-commits] [SCM] GNU PSPP branch, master, updated. v0.7.9-298-gd331e87 |
Date: |
Tue, 31 Jul 2012 06:04:02 +0000 |
This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "GNU PSPP".
The branch, master has been updated
via d331e87bf86af44e0bda66a12dd33670c30e7b50 (commit)
via 599a4f195959211502d17de3813ec70d3ad5950b (commit)
via 471c983e61d5924356b1428ee87d467536caf395 (commit)
via 0b2c91ffedd167c861b7ed250e5597aa0f4b0220 (commit)
from 127e4edd2968a7a566201ab7052976bb29b1182c (commit)
Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.
- Log -----------------------------------------------------------------
commit d331e87bf86af44e0bda66a12dd33670c30e7b50
Author: Ben Pfaff <address@hidden>
Date: Sun Jul 29 23:56:09 2012 -0700
var-type-dialog: Change entries to spin buttons, add validation.
The GtkEntry boxes used for entering and displaying width and
decimal places didn't do any validation that the width and decimal
places were valid for the selected format type, so it was possible
to enter values that couldn't actually be used. This commit changes
the GtkEntry boxes into GtkSpinButton widgets that, as a side
effect, validate correct values through their attached
GtkAdjustments. This is not just safer but easier to use.
commit 599a4f195959211502d17de3813ec70d3ad5950b
Author: Ben Pfaff <address@hidden>
Date: Sun Jul 29 23:09:09 2012 -0700
var-type-dialog: Reduce redundancy further.
set_format_from_treeview() and set_format_type_from_treeview() were
mostly common code.
commit 471c983e61d5924356b1428ee87d467536caf395
Author: Ben Pfaff <address@hidden>
Date: Sat Jul 28 14:18:40 2012 -0700
var-type-dialog: Reduce redundancy.
var_type_dialog_set_state() and on_toggle_2() had considerable
redundant code. This reduces it by adding a new function
on_active_button_change() that generalizes the two functions. I
also personally found the previous way of showing and hiding widgets
to be hard to follow; I think that the bitmap approach used here
is more straightforward.
This also consolidates the two separate signal handlers for each
button into one, and replaces the similar functions
select_treeview_from_format() and select_treeview_from_format_type()
by three functions find_format(), find_format_type(), and
select_treeview_at_index() that total less code.
commit 0b2c91ffedd167c861b7ed250e5597aa0f4b0220
Author: Ben Pfaff <address@hidden>
Date: Thu Jul 26 23:21:54 2012 -0700
var-type-dialog: Properly adjust formats when switching buttons.
The var-type-dialog based the default new format on the variable's
existing format when a button was clicked, and attempted to adjust
the width and decimals into valid range, but the adjustment wasn't
always correct, so in some cases it could pick an invalid format.
This commit uses fmt_fix_output() instead, which will always choose
a valid output format.
-----------------------------------------------------------------------
Summary of changes:
src/ui/gui/var-type-dialog.c | 561 +++++++++++++++++------------------------
src/ui/gui/var-type-dialog.h | 4 +-
src/ui/gui/var-type-dialog.ui | 24 ++-
3 files changed, 261 insertions(+), 328 deletions(-)
hooks/post-receive
--
GNU PSPP
[Prev in Thread] |
Current Thread |
[Next in Thread] |
- [Pspp-commits] [SCM] GNU PSPP branch, master, updated. v0.7.9-298-gd331e87,
Ben Pfaff <=