[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xlog-discussion] Cwdaemon... still trying...

From: John B. Egger
Subject: [Xlog-discussion] Cwdaemon... still trying...
Date: Fri, 09 May 2014 12:01:48 -0400
User-agent: Mozilla/5.0 (X11; Linux i686; rv:24.0) Gecko/20100101 Thunderbird/24.5.0

In September 2013 some in the group offered help but I never could get cwdaemon working. Trying again, with:

Kubuntu Trusty (14.04)
Xlog 2.0.11
Cwdaemon 0.9.5-1.1

Although /etc/default/cwdaemon shows START_CWDAEMON=yes, on this morning's boot-up "ps -A" did not show it running. Simply typing "cwdaemon" at the user prompt brought the warning that it had to be run as root, and "sudo cwdaemon" added it to the ps -A list. I followed the advice in /usr/share/cwdaemon/README and found parport0, parport_pc, and parport loaded (and the lp module not). I checked Synaptic to make sure netcat was installed (it is), and tried (in /usr/share/cwdaemon) "./cwtest.sh". Got "Press (CTRL-C) to interrupt..." and then hear and see nothing.

As for "Sound device," in /etc/default/cwdaemon, I've tried (c)onsole, (s)oundcard, and (b)oth, and hear nothing from the computer when either cwtest is run as above (last year, at least, I was hearing "Paris Paris" from somewhere inside the desktop) or when the F keys are used with Xlog and its Keyer running.

At some point I'll connect the parallel-port adapter I bought from another TenTec CW man (I know; the transistor switch is simple to build, and I bought the parts, but this was a lot easier) and, I hope, actually use the keyboard and contest modes Xlog offers.

Sorry to be persistent about this, but it doesn't seem as if it should be this hard! (Obviously I can't use CQRLog either [it also uses cwdaemon], which I'm not using but have been playing with a little.) Maybe my tale of woe will be of some use to somebody.

--John K3GHH

reply via email to

[Prev in Thread] Current Thread [Next in Thread]